1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

Kobelco hydraulic excavators

Discussion in 'Excavators' started by MR. KOBELCO, Oct 20, 2010.

  1. blankey85

    blankey85 Member

    Joined:
    Mar 30, 2015
    Messages:
    14
    Location:
    SW PA
    I'm having trouble diagnosing an issue with a 2004 Case CX-14. I'm not sure who is the actual manufacturer being as the service manual also applies to a Kobelco SK13SR.

    It has Kawasaki pilot valve body and a 3-cylinder Yanmar engine. I've posted looking for help with a hydraulic issue but haven't gotten any responses. So is this machine actually a Case or Kobelco?
     
  2. bigjimcor

    bigjimcor New Member

    Joined:
    Apr 24, 2015
    Messages:
    2
    Location:
    massachussetts
    hello i have a jsw BH80E s/n s5 -1092 IM having problems with the main pump im not sure how to set it have been looking for a repair manual for the machine i recently had pump resealed everything looked fine but the popet settings im not sure how to set any books or info on it would be greatly appreciated. tks jim
     
  3. J Miller Excava

    J Miller Excava New Member

    Joined:
    May 2, 2015
    Messages:
    2
    Location:
    Pennsylvania
    Why does my sk170-8 lose power and speed when it runs for a few hours. I mean a drastic reduction
     
  4. heavyrig

    heavyrig New Member

    Joined:
    May 4, 2015
    Messages:
    1
    Location:
    Hot Springs, AR
    I have a MDI Yutani MD180 and am needing the part numbers for the hydraulic filters. There are two. One big one in the main tank and one in the return for the hydraulics.
     
  5. Fordson dexta

    Fordson dexta Member

    Joined:
    Oct 10, 2010
    Messages:
    17
    Location:
    UK
    Hi all.

    I have chance of buying this digger in the pictures, think it is a SK50-05736. But a bit vague at the moment. Not entirely sure on year of manufacture but I have the serial number so guess this can be worked out.

    It is fire damaged, engine wiring loom is burnt out, the engine will run and with a bit of messing around I am told the hydraulics will work, but obviously needs a fair bit of fixing.

    Is it worth a go, are they any good? No experience of Kobelco, have a Komatsu though. Are parts, possibly a loom easy to come by, is there anything I need to be weary of?

    It doesn’t look to bad, been parked up for at least two years, so a bit green, doesn’t look to burnt and charred.

    TIA.
     
  6. Fordson dexta

    Fordson dexta Member

    Joined:
    Oct 10, 2010
    Messages:
    17
    Location:
    UK
  7. mudober

    mudober Well-Known Member

    Joined:
    Jan 3, 2010
    Messages:
    120
    Occupation:
    heavy equiptment operator
    Location:
    So. IL.
    Sk150

    Hello, I am looking at buying a 98 SK150 LC -4, for farm use. I believe it may need some new track chains. I am thinking they will cost around 3,000 for a pair. Am i about rite? Do you believe that this is a good series of machine. It will have a Cummings engine. Thanks for your insight. Mudober
     
  8. Colorado Digger

    Colorado Digger Senior Member

    Joined:
    Dec 3, 2008
    Messages:
    1,169
    Location:
    Carbondale,co
    Hello all, I bought a 06 sk350lc at auction and it had been running fine. We brought it up from DFW and it ran for the first month perfectly. Then the turbo went and we had it replaced. Now the machine is blowing a lot of smoke, like it is unburnt fuel and may be too rich. I have talked to Kobelco and they said they have seen the problem before. Last week the mechanics were at Hino school and will be back Monday. They are going to send someone up to update the computer. Anyone have experience in this?

    2015-05-04 07.50.20.jpg



    Thanks,CD
     
  9. Splash

    Splash Member

    Joined:
    Apr 26, 2010
    Messages:
    8
    Location:
    New Zealand
    Hi

    Anyone know what the electrical switch in the toolbox of an SK100W is for? little push button switch mounted top right of the tool box.
     
  10. Oils006

    Oils006 New Member

    Joined:
    May 14, 2015
    Messages:
    1
    Location:
    BC
    Does anyone have a sk035 coupe pdf?
     
  11. Oxbow

    Oxbow Senior Member

    Joined:
    Nov 22, 2012
    Messages:
    859
    Location:
    Idaho
    CD, could it be that the turbo failure may have plugged the aftercooler? I don't know anything about your machine, but it seems plausible that if it did not smoke before and suddenly began after changing the turbo that there is an air restriction somewhere (assuming the correct replacement turbo was installed). If the old turbo scattered then you would have residual pieces in the charge air cooler, and if it lost seals it may be plugged with oil.
     
  12. Plebeian

    Plebeian Senior Member

    Joined:
    Apr 2, 2009
    Messages:
    335
    Location:
    NZ
    Kobelco SK135SR vs Kobelco SK135SR-LC, is the LC with the longer tracks likely to be a better machine for working on slopes or is the standard SR tracks with less weight and less track length to power likely to have better climbing ability?
     
  13. qball

    qball Senior Member

    Joined:
    Dec 30, 2007
    Messages:
    1,072
    Occupation:
    local 150 operator
    Location:
    il
    Just spent the day on an sk500. Phenomenal hoe, incredibly fast, smooth and powerful. Very impressed.
     
  14. digger_hunter

    digger_hunter Well-Known Member

    Joined:
    Apr 20, 2012
    Messages:
    118
    Location:
    Germany
    Hi guys,

    Our Kobelco SK210-6 has developed a weird problem or we just didn't notice is before we bought it. Bascially when you move the arm in, towards halfway of the stroke when the arm is just outside of being vertical to the ground, the arm just falls about 6-10inches and bounces a bit and stope moving inwards. So its kinda like 10 inches before vertical its almost like the pressure on the return line drops or something and the arm just falls down and then the pressure seems to catch up after 2-3 seconds and it continues to move in. Pretty weird.

    Would be grateful if someone can point us in the right direction.

    Thanks
     
  15. samsonv8

    samsonv8 Active Member

    Joined:
    May 19, 2015
    Messages:
    32
    Location:
    uk
    sk75ur

    hi first time on here, have a sk75ur,yr 03815.very low on power, poor at climbing and digging, engine ok ,all filters changed .noticed some times the blade will not power down ,any ideas .thank you
     
  16. samsonv8

    samsonv8 Active Member

    Joined:
    May 19, 2015
    Messages:
    32
    Location:
    uk
    also need door and screen kobelco 006.jpg
     
  17. Pagey

    Pagey New Member

    Joined:
    Jun 8, 2015
    Messages:
    1
    Location:
    Sydney, Australia
    Hi, First time on the forum. I have a Kobelco SKO45 just using it on the farm, digging trenches, removing stumps, moving dirt and general lifting. Can someone tell me the capacity of the hydraulic system? I have a light on the control panel that I think is "low oil", I have topped up with 15L but still on? Thanks in advance for any assistance.
     
  18. racecoach

    racecoach Member

    Joined:
    Jun 1, 2013
    Messages:
    5
    Occupation:
    Business
    Location:
    Montreal
    I am looking at how to take off the drive engine cap to fix a seal. The drive engine is loosing it's oil on both side.
    Can anyone help me with this?
    Model Kobelco SK-60 Acera

    Thanks

    Patrik
     
  19. racecoach

    racecoach Member

    Joined:
    Jun 1, 2013
    Messages:
    5
    Occupation:
    Business
    Location:
    Montreal
    Cap removal on drive engine SK-60 Acera

    Hello I'm looking at how to remove the cap from my drive engine on my SK-60

    Anyone has the know how?

    Thank's

    Patrik
     
  20. racecoach

    racecoach Member

    Joined:
    Jun 1, 2013
    Messages:
    5
    Occupation:
    Business
    Location:
    Montreal
    I meant final drive engine...