1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

S570 M0251. Yes another charge pressure

Discussion in 'Skid Steers' started by Txhayseed, Nov 20, 2020.

  1. Txhayseed

    Txhayseed Well-Known Member

    Joined:
    Dec 23, 2019
    Messages:
    197
    Location:
    Texas
    S570 keeps throwing M0251 after about 5 minutes of running. Is the charge pressure sensor mounted in the fan motor on these guys ? Pulled it out to see about putting in a gauge but I don’t have any adapter that matches the threat pitch on that sensor. Also does anyone know what the pressures should be on this guy ? Thank