1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

S185 hydraulics won't feather.

Discussion in 'Compact Wheel Loaders' started by BDFT, Apr 29, 2012.

  1. BDFT

    BDFT Senior Member

    Joined:
    Sep 12, 2010
    Messages:
    265
    Location:
    Northwest BC
    I have a 2008 S185 with 2200 hours on it and lately the hoist hydraulics are becoming more and more difficult to "feather". I really noticed it today augering holes for footings. They were either on or off. If I slowly push the pedal nothing happens until the pedal reaches almost full travel and then, BAM, the boom goes up, or down. Made me look like a real pro today. I am suspicious that this has been getting progressively worse over the winter and I haven't noticed it plowing snow. I'm thinking control valve, a broken spring maybe? Any thoughts before I start tearing it apart?