1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

Mustang ML 42 Problem

Discussion in 'Compact Wheel Loaders' started by MasseyCatGuy, Dec 24, 2020.

  1. MasseyCatGuy

    MasseyCatGuy New Member

    Joined:
    Dec 24, 2020
    Messages:
    2
    Location:
    55355
    I have a 2004 Mustang ML42 wheel loader. It will not always start. Parking break is on, and warning lights activate on dash when key is turned on. It has a good battery (Dec 2019) and everything else works great when it runs. Where are the safety switches for the parking brake and ignition? Any other ideas on what to look for? The manual says nothing, and does not show any fuses/relays for this.