1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

multiquip 25kva isuzu full load setting

Discussion in 'Generators/Gensets' started by Midnightmoon, May 28, 2020.

  1. Midnightmoon

    Midnightmoon Active Member

    Joined:
    Nov 9, 2013
    Messages:
    29
    Location:
    Ny
    I had to replace timing cover I counted all the turns on all set screws took pictures and I must have missed a turn on the full load stopper. Engine dies during load test at 10amps. I adjusted it in 2 turns now dies at 24amps. Instead of guessing does anyone have full load stopper settings or for that matter complete govener setup? The isuzu manual I have doesnt have info. its a bv4le2 serial262696. After I got it all together I set hz to 61.5 idle was right at 1800. Multiquip doesnt have a spec on the full load stop. I believe thats my problem.