1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

Morbark M18 John Deere throttle Issue

Discussion in 'Forestry Equipment' started by Iggys6, Feb 8, 2019.

  1. Iggys6

    Iggys6 Well-Known Member

    Joined:
    Oct 10, 2016
    Messages:
    60
    Location:
    CT
    Hello I have a 2005 Morbark M18 with the John Deere Powertech 4.5L. The Chipper is amazing however just today a cel turned on for SPN 91 - FMI 3 (Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source). Says either the throttle switch or the wiring. I replaced the switch a couple months ago so I doubt it's that. I began tracing back the wiring but am finding resistance between a couple pins at the ECU connector. Just wondering if anyone has any tips or a wiring schematic?

    Thanks in advance
     
  2. mg2361

    mg2361 Senior Member

    Joined:
    Jul 5, 2016
    Messages:
    344
    Occupation:
    Equipment Technician
    Location:
    Pennsylvania
    Need the engine serial number. From that I can get you a general Deere schematic. I am not sure but I think the dash on the Morbark is from them and not Deere, but the schematic should still help. Obviously if there is any corrosion on the wiring/connectors you want to take care of that.
     
    Vetech63 likes this.