1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

JLG 45IC trouble shooting ignition

Discussion in 'Other Construction/Demolition Equipment' started by want 2 get high, Sep 5, 2018.

  1. want 2 get high

    want 2 get high Member

    Joined:
    Aug 14, 2018
    Messages:
    12
    Location:
    IL
    Hi all,
    Another problem with the lift. Will start and run a very short time and die. I have checked the pulsing ground at the coils which it does have but when you first start to crank the engine the pulsing ground is not there for a short amount of time and then returns. Is this normal to have the delay of the pulsing ground? Is there a way to check the ignition trigger?
    This is the 3 cylinder gas/lp model. When it is running and dies it is sudden which makes me think it is not fuel related.
    Would an ignition module or ignition trigger fail this way? I will restart after a little and die all over again.
     
  2. want 2 get high

    want 2 get high Member

    Joined:
    Aug 14, 2018
    Messages:
    12
    Location:
    IL
    Up date.
    I guess this has been the odd chance that I would have a problem with both fuel systems at the same time. I had been running the lift on LP because of hiccups I was having on the gas side, (which I guess was the pump failing) when it stopped running on the LP. Not considering that both fuel systems would be a problem at the same time I started looking at ignition. I ended up using an old timing light and it seemed to be operating correctly. This lead me to fuel. I hooked up a temporary fuel tank and gravity fed the carb and the engine runs. While running I put the fuel line from the on board tank into a gas can and barely had any gas flow at all. Still have power to the fuel pump so I replaced the fuel pump with an after market pump from Autozone. I still have power to the LP solenoid valve but it will not run on LP. I guess I will have to figure that one out as well.
    Hope this will help someone else in the future.