1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

JLG 40H no proportional controls

Discussion in 'Forklifts/Telehandlers' started by BrownBear, Mar 13, 2020.

Tags:
  1. BrownBear

    BrownBear Member

    Joined:
    Jan 29, 2020
    Messages:
    9
    Location:
    Wawa, Ontario
    Baby's first lift, a JLG 40H 1997 with Ford engine and 3 PQ Controls at the platform. s/n 047753030030541

    All the ground controls and platform switch controls work as expected but none of the proportional controls does anything. PO says they worked intermittently and in certain positions before the lift was parked last year. Wiring appears intact and undisturbed. Any suggestions on where to start troubleshooting?
     
  2. excavator

    excavator Senior Member

    Joined:
    Oct 16, 2006
    Messages:
    901
    Location:
    Pacific North West
    Check to make sure you're getting voltage to the proportional control dump valve. If I remember right it's located on the right side of the radiator area.