1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

Genie Z-45/25J Electrical Problem

Discussion in 'Other Construction/Demolition Equipment' started by Alan Caro, Nov 2, 2021.

Tags:
  1. Alan Caro

    Alan Caro Member

    Joined:
    Oct 19, 2021
    Messages:
    17
    Location:
    Puerto Rico
    This Genie is having a problem where if you leave it turned on for an extended amount of time (30 minutes or so) it’ll turn off when you press the operate pedal, then if you turn it on, it’ll quickly turn off again until you wait 5 minutes and remove and insert a yellow fuse.

    any ideas on what may be the cause of this problem? We tried many mechanical things but it seems to be more of an electrical problem now…

    i attached an image of the fuse box (Yellow fuse is the one temporarily fixing the problem)
     

    Attached Files:

  2. Alan Caro

    Alan Caro Member

    Joined:
    Oct 19, 2021
    Messages:
    17
    Location:
    Puerto Rico
    Did not upload, here they are!
     

    Attached Files: