1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

Gehl Dynalift

Discussion in 'Forklifts/Telehandlers' started by mrhege, Mar 4, 2010.

  1. mrhege

    mrhege Member

    Joined:
    Mar 3, 2010
    Messages:
    6
    Location:
    Penna.
    We purchased a 99 Gehl 6LDL telehandler last spring to use in our constructing buisness, overall it runs fine but we have 1 main issue and several questions we can not figure out. We purchased a parts and service manuals but they do not give much information on these matters.
    #1- what does the axle alignment switch do?
    #2- what does the transmission de-clutch switch do?
    #3- Main Problem is the 4 wheel drive does not engage, what activates the 4 wheel drive and what do we trouble shoot to help find out the problem.
    Both switches mentioned above have power in and power out but we cannot detect any functions working. We would appreciate any info that you can give. Thanks
     
  2. willie59

    willie59 Super Moderator

    Joined:
    Dec 21, 2008
    Messages:
    12,475
    Occupation:
    Service Manager
    Location:
    Knoxville TN
    Welcome to the forum mrhege. :usa

    Do you mean a Gehl DL-6? I've worked on DL-8's some years ago, doubt they're much different. Axle alignment switch? Not familiar with that. Do you mean the steering selector switch? Can't remember for sure how the de-clutch works on those machines, but the de-clutch function would be so you could disconnect drive in order to throttle engine to rapidly raise or lower the boom without having to select N on your fwd/rev lever. The switch may enable the de-clutch to be operated by slightly depressing brake pedal, or selecting the brake pedal to not de-clutch, can't remember. Don't remember how the 4wd works. I would think if you don't have a 4wd selector switch on the dash somewhere, then it would be in 4wd all the time and you have a problem with drivetrain somewhere. As for electrical problems, one thing I used to see frequently on DL-8 machines is bad connections where the relays plug into the relay board. I've had to pull the relay boards out and repair spade terminal connections where they connect to relay terminals on the 8's. Hope this helps a little. ;)
     
  3. mrhege

    mrhege Member

    Joined:
    Mar 3, 2010
    Messages:
    6
    Location:
    Penna.
    We have got the axle alignment switch to work, think it was some dirty connections, had to adjust the sensor on top of rear axle also. If there is any other info on trouble shooting the 4 wheel drive we would appreciate it. Also is there any decent online parts stores for a Gehl DL-6L40 telehandler? Thanks for the info
     
  4. barklee

    barklee Senior Member

    Joined:
    Aug 5, 2009
    Messages:
    898
    Location:
    ohio
    for parts try Company Wrench (in Ohio) or a Gehl farm dealer. Alot of these lifts are sold through ag dealers
     
  5. azrich487

    azrich487 New Member

    Joined:
    Sep 20, 2010
    Messages:
    2
    Location:
    Buckeye, AZ
    I dont mean to hijack your thread but i cant start one of my own at this time. Have you had a "Low accumulator pressure" light ever come on and lose everything, no steer, no boom, no forward or reverse? This is the problem that I have and there is nothing in the manuals to address this.
     
  6. jhillock

    jhillock Member

    Joined:
    Oct 3, 2011
    Messages:
    6
    Location:
    OREGON
    Dl6l


    i have the same problem what did you do to fix it john
     
  7. jhillock

    jhillock Member

    Joined:
    Oct 3, 2011
    Messages:
    6
    Location:
    OREGON
    Dl6l

    still not fixed
     
  8. azrich487

    azrich487 New Member

    Joined:
    Sep 20, 2010
    Messages:
    2
    Location:
    Buckeye, AZ
    There is a coupling between the engine and transfer case that broke. I had to pull the engine and replace it. Not a hard job and only took about two hours start to finish.