1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

Ex120-2, solve issues, news one crop up.

Discussion in 'Excavators' started by JDCrow, Jun 13, 2021.

  1. JDCrow

    JDCrow Well-Known Member

    Joined:
    Sep 25, 2020
    Messages:
    102
    Location:
    Redmond, Or
    My 120 is functioning great now.
    Did a conversion kit and happy with results.

    I also had a friend help me with new inner/outer harness as when I was probing around discovered just how bad the old one was with breaks and splices.

    One issue now is, all warning lights and buzzer stay on when started. They go off with key, as does engine. But hour meter keeps turning. Have to disconnect relay to get the meter to stop. But plug relay back in and it doesn’t start back up.

    Also thumb now bleeds off in either direction, which I will try and figure out.

    Reading past posts and looking into alternator, fuseable link, battery relay
    thanks for any insight
     
  2. mg2361

    mg2361 Senior Member

    Joined:
    Jul 5, 2016
    Messages:
    2,704
    Occupation:
    Equipment Mechanic/Technician
    Location:
    Pennsylvania
    Do they go out and buzzer stop when the engine is revved up?
     
  3. uffex

    uffex Senior Member

    Joined:
    Jan 23, 2012
    Messages:
    2,202
    Occupation:
    Admin
    Location:
    Lincoln UK
    Good day
    As a general rule the hour meter that runs with a stationary engine points to a alternator diode failure.
    Kind regards
    Uffex
     
    Last edited: Jun 15, 2021
  4. JDCrow

    JDCrow Well-Known Member

    Joined:
    Sep 25, 2020
    Messages:
    102
    Location:
    Redmond, Or
    Good morn, we swapped the original cab harness back in and everything went back to normal.

    It appears that the alternator has been changed out to a non-hitachi one.