1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

caterpillar 3056e no starts

Discussion in 'Screen/Wash Plants' started by rmllarue91, Apr 4, 2016.

  1. rmllarue91

    rmllarue91 Senior Member

    Joined:
    Apr 17, 2014
    Messages:
    578
    Occupation:
    field technician
    Location:
    northeast pa
    Tube style voltage regulator sits above ecm controls ground and power to injection pump. Best it so check power and ground at pump when trying to start
     
    Tenwheeler likes this.
  2. Tenwheeler

    Tenwheeler Senior Member

    Joined:
    Dec 16, 2016
    Messages:
    660
    Location:
    Georgia
    That works. Do not have pins to connect info at home. The cover has to be removed from the pump electrical connector for that.
    These engine fuel line systems are also harder to bleed than most anything else.
     
    rmllarue91 likes this.
  3. Kingston1990

    Kingston1990 New Member

    Joined:
    Nov 8, 2020
    Messages:
    1
    Location:
    UK
    Hi! to follow on from the above...Intermittent starting issue on chafer mirage crop sprayer with CAT 3056e engine. Couple of previous fault codes that will not go away (ECU update was suggested but not yet got round to it) and new fault code "fuel temp signal loss". The engine stopped dead whilst driving on the road. A booster pack was then used to start it. Drove fine. Booster pack removed and I stopped engine, it would not restart. Left overnight with batteries charging, started fine in the morning. Left running for a while and then I cut the engine and would not restart. Wiring issue somewhere I presume...but where to start?!
     
  4. Tenwheeler

    Tenwheeler Senior Member

    Joined:
    Dec 16, 2016
    Messages:
    660
    Location:
    Georgia
    I have heard of some people that were not happy after ECU updates on road trucks with Cat"s. Therefore I would not rush into that.
    Know nothing about your fuel temp signal loss. Maybe someone else or search for an online manual for your machine.
    Suggest you start by checking voltage in and out of the voltage control module. Thank you need at least 18V going to the pump while cranking.
     
  5. rmllarue91

    rmllarue91 Senior Member

    Joined:
    Apr 17, 2014
    Messages:
    578
    Occupation:
    field technician
    Location:
    northeast pa