1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

CAT 329 Track Function

Discussion in 'Excavators' started by ms0115, Jan 7, 2020.

  1. ms0115

    ms0115 Senior Member

    Joined:
    Mar 3, 2014
    Messages:
    285
    Location:
    Ethridge, TN
    Serial #CAT0329ETPLW00668 Problem- periodic loss of one track function. Shows a data link code as well as the 3 others in the picture. I had CAT come out in November and they did an update on data link per service bulletin. This did not help the problem. Replaced the swing priority solenoid and the stick cylinder extend pilot pressure sensor. The codes cleared except for the data link. The machine operated fine for 3 weeks with no issues. Now the track started to loose function again and the codes came back. Any advice or direction on how to proceed would be appreciated.
     

    Attached Files:

  2. Mark250

    Mark250 Senior Member

    Joined:
    Aug 30, 2015
    Messages:
    1,169
    Occupation:
    heavy equipment technician
    Location:
    victoria,Australia
    hi,I am assuming cat re-flashed the monitor software for your communication errors,but I don't see that as the source of your problem for loss of track function.
    The track system still uses a pilot oil system that controls the main control spools for travel
    There is a bulletin out for the travel check valve in the main control valve .Has that been checked and or replaced?
    Has any recent work been done that could be related?
    Is only one track affected? If so which one?
    If only one track is affected try swapping the travel pressure switch's, under the floor on the travel pilot control valve to see if the problem moves
    Does the track stop or slow down?
    is the machine fitted with the straight travel pedal?
    Are any other functions affected?
    Have you checked for debris in the filters?
    Does the problem appear to be temp related ?
    Can you recreate the fault yourself?
    Sorry for all the questions just trying to get a feel for your problem

    Mark
     
    Last edited: Jan 8, 2020
  3. Mark250

    Mark250 Senior Member

    Joined:
    Aug 30, 2015
    Messages:
    1,169
    Occupation:
    heavy equipment technician
    Location:
    victoria,Australia
    travel pressure switch's #2 and #8
    upload_2020-1-8_12-38-8.png
     
  4. ms0115

    ms0115 Senior Member

    Joined:
    Mar 3, 2014
    Messages:
    285
    Location:
    Ethridge, TN
    The problem has been intermittent. The reflash was dealer suggested. No the travel check valve has not been checked. Could you give me any more info on the check valve. Location
     
  5. ms0115

    ms0115 Senior Member

    Joined:
    Mar 3, 2014
    Messages:
    285
    Location:
    Ethridge, TN
    Is there any way to get parts numbers? Thanks for the help
     
  6. ms0115

    ms0115 Senior Member

    Joined:
    Mar 3, 2014
    Messages:
    285
    Location:
    Ethridge, TN
    At the cat dealer and they are having trouble finding the parts. 3 hour ride to the job just taking parts to be safe
     
  7. ms0115

    ms0115 Senior Member

    Joined:
    Mar 3, 2014
    Messages:
    285
    Location:
    Ethridge, TN
    They got it figured out on parts. Will up date tomorrow.