1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

2014 Wacker RD12A - No Spark/No Fuel - "tried everything"!

Discussion in 'Rollers' started by Chris - Wright Assets, May 12, 2022.

  1. Chris - Wright Assets

    Chris - Wright Assets New Member

    Joined:
    May 12, 2022
    Messages:
    2
    Occupation:
    Business Owner
    Location:
    Ontario, Canada
    Hey everyone, new member.......just picked this unit up, was told needs starter.......starter is fine. but: determined engine (Honda GX630H) is not getting fuel nor spark.

    Tested:
    Battery - fine, Fuel - lots, oil level - perfect, Ignition - fine, fuses - fine, fuel solenoid - fine (fuel at valve), coil magnet - fine.

    Power to relays (there are 3 identical) and swapped plugs to see if changed anything - no change.

    Could be?: Coils (but why would both f up same time and no fuel delivery), fuel pump (but why no spark same time), relays (power at relays, one not clicking but swapped out and no change).

    I will check the fuel pump directly next but the plugs are dry, and cannot get spark from either cylinder. It seems there is a protection thing i'm not seeing. The only external thing is that there was no parking brake hooked up, i've seen instances where an engine wont turn over without the parking brake engaged but the engine turns over no problem.

    Any help would be appreciated!

    Chris
     
  2. Tags

    Tags Senior Member

    Joined:
    Feb 19, 2012
    Messages:
    1,389
    Location:
    Connecticut
    There is no brake safety hooked to the starter circuit, at least on mine, and mine is an older model I believe. Pretty sure the drive control does have a safety and it won’t start if in fwd or rev. So you’ve confirmed no spark? How?Turning engine over with plugs out but still plugged in?
     
  3. Chris - Wright Assets

    Chris - Wright Assets New Member

    Joined:
    May 12, 2022
    Messages:
    2
    Occupation:
    Business Owner
    Location:
    Ontario, Canada
    Confirmed no spark by grounding plug and screwdriver method. (No fancy timing light yet). Talked to the guys at Battlefield (Cat rental store) today and they are perplexed as well, their thought is it has to do with bad oil sensor or some kind of oil related issue.....I will bypass that and report back. Watching hockey/having beers tonight!
     
    Tags likes this.