1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

2008 TL230 fuel shutoff solenoid location

Discussion in 'Compact Track/Multi Terrain Loaders' started by Z'mnypit, Oct 17, 2020.

  1. Z'mnypit

    Z'mnypit Active Member

    Joined:
    Sep 16, 2010
    Messages:
    43
    Location:
    South
    Can anyone tell me where the fuel shutoff solenoid is on a 2008 TL230? I looked until dark all over the injector pump and see no 3 wire solenoid. I do the a magnetic sensor with a black and white wire. Was that it?
     
  2. thepumpguysc

    thepumpguysc Senior Member

    Joined:
    Mar 18, 2010
    Messages:
    5,504
    Occupation:
    Master Inj.Pump rebuilder
    Location:
    Sunny South Carolina
    If u have a mechanical injection pump that sits in its own little slot, the s/o solenoid should b screwed into the pump base, usually on the left side.. looks like a small Red Bull can.
    Although u don’t give us much to go on.. what engine.. what fuel system.??
     
  3. skata

    skata Senior Member

    Joined:
    May 10, 2007
    Messages:
    875
    Location:
    midwest
    Not sure about your machine, but on a tl140 you have to remove belly pan to see the solenoid.
     
  4. Z'mnypit

    Z'mnypit Active Member

    Joined:
    Sep 16, 2010
    Messages:
    43
    Location:
    South
    It's a 2008 Takeuchi TL230 with yanmar 4TNV8 engine. All oem fuel system. Just got in it one morning and it wouldn't start but ran fine the day before. It will eventually start after spinning over for a few seconds but lope very badly and the throttle is unresponsive as it doesn't change the rpm even when full throttle. Bled the injection pump, injectors and still lopes. Any suggestions?