1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

TZ50 auto level

Discussion in 'Forklifts/Telehandlers' started by razerface, Sep 4, 2018.

  1. razerface

    razerface Well-Known Member

    Joined:
    Aug 9, 2009
    Messages:
    65
    Location:
    ohio
    i fixed the basket auto level, now i need to fix the machine auto level. Nothing happens when i press the auto level button. The stabilizers will go down when i do them manually, or each button seperately.

    Where do i start to troubleshoot this? Is the autolevel module testable?
     
  2. razerface

    razerface Well-Known Member

    Joined:
    Aug 9, 2009
    Messages:
    65
    Location:
    ohio
    Anybody know?
     
  3. razerface

    razerface Well-Known Member

    Joined:
    Aug 9, 2009
    Messages:
    65
    Location:
    ohio
    Anybody?
     
  4. Ricothebear

    Ricothebear Active Member

    Joined:
    Jun 22, 2017
    Messages:
    25
    Occupation:
    Project manager
    Location:
    Winnipeg, Manitoba Canada
  5. razerface

    razerface Well-Known Member

    Joined:
    Aug 9, 2009
    Messages:
    65
    Location:
    ohio
    Last edited: Sep 18, 2018
    Ricothebear likes this.
  6. razerface

    razerface Well-Known Member

    Joined:
    Aug 9, 2009
    Messages:
    65
    Location:
    ohio
    Well, that tech tip paper is only half there. It stops after step 5. It lists step 6, but the step is blank and does not say what to do with the 7/16 wrench.

    The tip on noisy turntable has incorrect p/n on it. Figured that out after 40 minutes of phone calls. Too tired to call about this one today!

    I looked up parts costs. This problem is too expensive to start replacing parts. I’ll start tracing wires the hard way tomorrow.
     
  7. tool_king

    tool_king Senior Member

    Joined:
    Mar 29, 2010
    Messages:
    1,307
    Occupation:
    road mechanic owner
    Location:
    new jersey
    What is you email address I can send you the service manual for it .
     
  8. razerface

    razerface Well-Known Member

    Joined:
    Aug 9, 2009
    Messages:
    65
    Location:
    ohio
    Thanks, Sent you a pm. I have the service manual downloadable from genie, but it does not give specifics on working on the leveling system. You have something that does give hints?
     
  9. razerface

    razerface Well-Known Member

    Joined:
    Aug 9, 2009
    Messages:
    65
    Location:
    ohio
    I dont know why, but now it works halfway. When i hold the buttons, the legs come down until they all contact the ground, the back raises, then it all stops and the level module starts beeping. It seems to take a long time for this to happen too, very slowly.

    I have done nothing but trace wires. The connectors are clean with dielectric grease in them. Also i have been messing with the valves for the emergency hand pump sometimes too as the hand pump does not work. I wanted to make sure they are all closed. The directions say the machine will not run with them opened,,but mine does. Don’t know if fiddling with them is related to self level starting to work,,just mentioning all facts.

    Also took module off to see under it,,,,shook it real hard,,,think that helped? lol
     
    Last edited: Sep 20, 2018
  10. razerface

    razerface Well-Known Member

    Joined:
    Aug 9, 2009
    Messages:
    65
    Location:
    ohio
    I started working again after i posted above comments on what it did yesterday.

    Now it does nothing again when i try to auto level,,unless while holding the yellow and autolevel buttons, i quickly press and release any of the four outrigger buttons. Then it starts to auto level, but usually just raises the back legs. Once it took them all the way and the module sounded off like it was leveled. The bubble was barely in the big circle.

    The timer changes the speed of the clicks and beeps, so i am assuming it works, but only getting 12 volts on it instead of 24v.

    I also noticed that when i press any of the outrigger buttons, without pressing up or down button,,the machine groans a little and barely moves whichever leg associated with the button i pressed. This must be related to the problem.

    Could a bad auto level module do all this?
     
  11. razerface

    razerface Well-Known Member

    Joined:
    Aug 9, 2009
    Messages:
    65
    Location:
    ohio
    I changed out the relay with an unused one. No change. I am going to replace the timer. As i play with everything, the timer seems to influence everything. I try adjusting it like the tech tip says, and it goes from no leveling at all to extending the legs all the way,,no in-between.
     
  12. Engineer44

    Engineer44 Member

    Joined:
    Nov 30, 2017
    Messages:
    17
    Location:
    Portland
    Any progress on your auto level issue? I’ve been watching this thread because I have a TMZ. Would be interested to hear the outcome if/when you figure it out.
     
  13. razerface

    razerface Well-Known Member

    Joined:
    Aug 9, 2009
    Messages:
    65
    Location:
    ohio
    I replaced the timer. It auto leveled twice with the back slightly high. I will play with the timing now as soon as i get back from vacation. The new timer makes a buzzing noise while the old one was silent. As i turn the timer knob, the buzzing noise changes length matching my adjustment. I am assuming that means the old one was bad,,,anyone else get buzz from timer while auto leveling?
     
    Last edited: Oct 17, 2018
  14. razerface

    razerface Well-Known Member

    Joined:
    Aug 9, 2009
    Messages:
    65
    Location:
    ohio
    Finally decided to go ahead and order the level module. I can find nothing else wrong. It will be here next week.