1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

TH460B won't go into gear

Discussion in 'Forklifts/Telehandlers' started by Pilgrimjt, Feb 14, 2015.

  1. Pilgrimjt

    Pilgrimjt Member

    Joined:
    Feb 13, 2015
    Messages:
    5
    Location:
    Canada
    I have a 2005 Cat TH460B that I've owned for about six years and has worked well for the most part but has had transmission related issues a fair bit. I had to replace the shift rail sensors about four years ago. For the last two and a half years it's had this problem of not going into gear at times, more so in spring and fall, but the last few weeks it's been really bad - almost daily. So far I've found nothing consistent with getting it going again except to wait. Sometime restarting a few times does it, sometimes not, other times just leaving the machine idling for a while does it. When I had the shift rail problem I was able to get the computer codes by cycling the key, but with this there are never any codes that come up. Just wondering if anyone here has had a problem like this or any experience with this?
     
  2. Per Eriksson

    Per Eriksson Senior Member

    Joined:
    Oct 24, 2007
    Messages:
    533
    Location:
    Sweden
    How's your oil and filter, any signs of metal in the tank?
     
  3. Pilgrimjt

    Pilgrimjt Member

    Joined:
    Feb 13, 2015
    Messages:
    5
    Location:
    Canada
    I did a complete service job last fall and everything looked good. I'm fairly certain it's something electronic, I'm just not sure what.
     
  4. Dualie

    Dualie Senior Member

    Joined:
    Feb 24, 2007
    Messages:
    1,371
    Location:
    Nor Cal
    had the same problem with a rental the ended up replacing the shift selector and doing a recalibrate.
     
  5. deniden

    deniden Member

    Joined:
    Jun 11, 2013
    Messages:
    8
    Location:
    Russia
    There are all the instructions and spare parts catalog cat telehandler

    Who are interested in writing
     
  6. CM1995

    CM1995 Super Moderator

    Joined:
    Jan 21, 2007
    Messages:
    8,798
    Occupation:
    Running what I brung and taking what I win
    Location:
    Alabama
    I would look at the shift selector also. 420D had the same problem of going into reverse only when it wanted too.
     
  7. Dualie

    Dualie Senior Member

    Joined:
    Feb 24, 2007
    Messages:
    1,371
    Location:
    Nor Cal
    They never did fix my biggest pet peeve about the damn thing which was you had to take your foot full off the brake before it would "catch" a gear. so it wouldnt hold well if you shifted from forward to to reverse while stopped on an incline.
     
  8. CM1995

    CM1995 Super Moderator

    Joined:
    Jan 21, 2007
    Messages:
    8,798
    Occupation:
    Running what I brung and taking what I win
    Location:
    Alabama
    The TH460B I had the dealer replaced the instrument cluster twice due to gauges not working, never had a problem with the trans. Got rid of it after a few years but still have ol' Blue a '90's Gradall. Still cranks, runs and lifts.;)
     
  9. Pilgrimjt

    Pilgrimjt Member

    Joined:
    Feb 13, 2015
    Messages:
    5
    Location:
    Canada
    So if it is the shift selector, would that not set a diagnostic code? So far I've never been able to retrieve any codes when it's not going into gear. It's been working good again yesterday and so far today.
     
  10. southernman13

    southernman13 Senior Member

    Joined:
    May 13, 2008
    Messages:
    535
    Occupation:
    Retired
    Location:
    Florida,Ga,Tn
    Where do these codes show up? I have the same machine and it's worked very well but now I'm having issues with the steering. It is stuck in what seems like two modes. Crab and 4 wheel steer. It won't domeither one correct. Theres 2 steering icons lit up on the dash as well and one of them is blinking. Any ideas?
     
  11. deniden

    deniden Member

    Joined:
    Jun 11, 2013
    Messages:
    8
    Location:
    Russia
    th.jpg

    There are all the telescopes full information

    Anyone interested?
     
  12. deniden

    deniden Member

    Joined:
    Jun 11, 2013
    Messages:
    8
    Location:
    Russia
  13. Pilgrimjt

    Pilgrimjt Member

    Joined:
    Feb 13, 2015
    Messages:
    5
    Location:
    Canada
    southernman13, the codes will be displayed on the instrument panel in the digital windows. The way to get them to display, if there are any active codes, is to start with the ignition in the off position and cycle the key three times within ten seconds and leave it in the on position. This puts the panel in service mode.
     
  14. southernman13

    southernman13 Senior Member

    Joined:
    May 13, 2008
    Messages:
    535
    Occupation:
    Retired
    Location:
    Florida,Ga,Tn
    Thanks Pilgrim. Not sure what the code will be if it throws on but I'll look!
     
  15. ANDREW C

    ANDREW C New Member

    Joined:
    Feb 13, 2019
    Messages:
    3
    Location:
    erie,co
    Did you have any luck with this problem? I have the same machine model with the exact same problem
     
  16. Pilgrimjt

    Pilgrimjt Member

    Joined:
    Feb 13, 2015
    Messages:
    5
    Location:
    Canada
    Yes we did figured it out eventually. It ended up being an electronic proportioning valve that was not working intermittently. The machine had to be calibrated after the new part was in. It's worked flawlessly since.