1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

Terex TA400 Weird Shifting Issues

Discussion in 'Other Earthmoving Equipment' started by rildin, Mar 14, 2018.

Tags:
  1. rildin

    rildin Member

    Joined:
    Dec 20, 2016
    Messages:
    15
    Location:
    Kansas
    Hi! This is a 2010 Terex TA400 with SN: A9821095. The problem is a bit confusing, would anyone have an idea what could be causing this:

    Let's say the vehicle is parked. The driver can start it, and shift from park to 1st. The shifter moves, and the driver can move forward. However, the truck will not shift into a higher gear. If the driver stops and shifts into reverse, the truck will still move forward in 1st.

    After shutting off and restarting the truck, if you move the shifter to reverse, the truck will move backwards. If you then stop and move the shifter to 1, the truck will continue in reverse.

    Any ideas?
    Thanks,
    Rildin.
     
  2. GaryHoff

    GaryHoff Senior Member

    Joined:
    Feb 26, 2009
    Messages:
    681
    Occupation:
    Heavey Equipment Mechanic
    Location:
    Alberta, Canada
    What are your fault codes?

    The transmission is staying in the last successful gear that it was in. This could be due to a number of faults, possibly a faulty speed sensor. Need some fault codes to make a informed suggestion.
     
  3. rildin

    rildin Member

    Joined:
    Dec 20, 2016
    Messages:
    15
    Location:
    Kansas
    Sorry for the long delay in replying, I had a short hospital stay. Since then, I went out to the site and checked the truck. I have not much experience with these trucks, but I do have some mechanic and electronic technician experience. I checked the fuses and relays, and had another delay while I waited for delivery of the relays. I changed 3 fuses, and found that about 3/4 of the relays tested bad. So I replaced all of the relays. I originally had several engine codes, and I think 3 transmission codes. After clearing the transmission codes, only one came back. I also did a test drive so I could have a first-hand description of the symptoms.

    The symptoms I experienced were: Truck started well, warmed up normally. Parking brake disengaged as expected. I placed the stick into the "D" position and drove forward. It drove normally, but would not shift. As the truck was given more fuel, the speed increased somewhat, as did the rpms, but it did not shift. I changed manually to gears in sequence, looking for a shift. It finally shifted to a different gear when the stick was in "4." At that point, after "feeling" the shift, the rpms went back down, but the speed increase was minimal. I stopped, the brakes worked normally. At this point in the test drive, the gear was "stuck." The stick was placed back in "D" and the truck went forward. In "N" it also went forward, and in "R" it also went only forward. We had to turn the truck off, restart it, and it was no longer stuck in gear, but it still wouldn't shift.

    There is only one transmission code showing, which is: P2714.
    Any help is appreciated.

    Thanks,
    Rildin.
     
  4. rildin

    rildin Member

    Joined:
    Dec 20, 2016
    Messages:
    15
    Location:
    Kansas
    Bump... hoping someone can help.
     
  5. laycobeau

    laycobeau Well-Known Member

    Joined:
    Jul 8, 2013
    Messages:
    105
    Occupation:
    Lead electronic technician
    Location:
    Tulsa Ok. beau.bowlan@lei-corp.com
    Code is

    P2714 Pressure Control Solenoid 4 (PCS4) Stuck Off

    see attached manual
     

    Attached Files: