1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

Telescopic JCB Forklift 516-40

Discussion in 'Tractor/Loader/Backhoes' started by Eoghan Murray, Nov 17, 2021.

  1. Eoghan Murray

    Eoghan Murray New Member

    Joined:
    Nov 17, 2021
    Messages:
    3
    Location:
    Ireland
    Just wondering has anyone had a similar experience as mine and if so how did they fix it. My forklift will turn on a drive perfect for 10-15minutes and then the forklift will stop driving, the engine and hydraulics stay working but the forklift will not drive forwards or back wards. Have any of ye came across this issue before and if so were ye able to fix it. Thanks in advance.
     
  2. nova481

    nova481 Well-Known Member

    Joined:
    Sep 8, 2010
    Messages:
    158
    Occupation:
    Retired Union Electrician
    Location:
    Howell NJ
    Hi
    There is another section of this forum titled:
    Forklifts/Telehandlers
    You might want to post your question there.
    Ron
     
  3. skata

    skata Senior Member

    Joined:
    May 10, 2007
    Messages:
    1,293
    Location:
    midwest
    Is there a Declutch pedal, or a declutch button on the boom control handle? Could be an issue with those switches. Also check parking brake sensor. Sounds electric related. Trans engages with solenoids getting activated. And parking brake and declutch switches deactivate the trans.
     
  4. Eoghan Murray

    Eoghan Murray New Member

    Joined:
    Nov 17, 2021
    Messages:
    3
    Location:
    Ireland
    Hi Skata, we thought it could be an issue with the brakes sensors so had that replaced but still didn’t fix anything. There is no declutch pedal or switch on it as far as I am aware. Thank you.
     
  5. Tinkerer

    Tinkerer Senior Member

    Joined:
    May 21, 2009
    Messages:
    7,086
    Location:
    The shore of the illinois river USA
    Do you have the service manual for it ?
    I found this, but I don't know if it is any help for you.
    A curser click on the image will enlarge it.

    JCB-516-40-pdf.jpg