• Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

Telescope problems grove rt890e

Crane2890

New Member
Joined
Aug 16, 2014
Messages
2
Location
Houston Tx
Occupation
Crane Mech for Maxim Crane Works
I have a 90 ton grove that when your scoping in on automatic mode only. The tele cyl hesitates like your letting your foot of the tele pedal and getting back into it. Have replace both tele pressure switches for extend and retrac as well as the foot pedal. Did all the pressure checks and all pressures check out within the tolerances required by the service manual. Only does it at higher rpm. 1500 to 2000. And only on retract. Has anyone ran into this. I'm pulling my hair out here
 

crane operator

Senior Member
Joined
Mar 27, 2009
Messages
8,304
Location
sw missouri
Does it, in automatic mode, ramp the speeds up and down, independent of the status of the foot pedal? I know earlier groves, on automatic, would start slow on movement, then speed up in the middle, then slow back down at the end of a telescope sequence. That speed happens independent of the position of the foot pedal, and I think on the earlier ones was based on the reading of lmi on boom length.

If that 90 is a latching pin boom, I would guess its speed may be controlled by the computer. I think I would be looking for loose, bad connections, or a bad board. The ramping up and down of speed is probably based on some microvolt difference output from the board. If its temporarily loosing signal, it would be just like you were getting in and out of the pedal.
 

Crane2890

New Member
Joined
Aug 16, 2014
Messages
2
Location
Houston Tx
Occupation
Crane Mech for Maxim Crane Works
Agreed

Yes I'm in agreement with you im gonna check it out more tomorrow and hopefully come up with a solutions and fix
 

that guy

New Member
Joined
Oct 19, 2023
Messages
2
Location
California
Help, I am working a company that has a Grove RT880e, when you go to scope out the boom it does not telescope, but only one section goes out. I can't see or find anything in the cab or the manual regardless a switch or setting for boom telescoping. Please point out what I am obviously missing! Thank you
 
Top