1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

Removed Engine gauge, now hydraulics won’t work

Discussion in 'Dozers' started by Victoria Luper, May 10, 2021.

  1. Victoria Luper

    Victoria Luper New Member

    Joined:
    May 10, 2021
    Messages:
    3
    Location:
    Bogalusa, La
    2001 New Holland Dozer DC70 LCP, my dozer had been running perfectly fine, I tried replacing the engine temperature gauge, and my dozers blade stopped working and the tracks won’t move. I messed with some of the wires in the dash and a switch on the right side panel and the blade will work for a little bit and all my gauges work but still not the tracks. HELP!
     
    Tarhe Driver likes this.
  2. JBrady

    JBrady Well-Known Member

    Joined:
    Jan 24, 2019
    Messages:
    133
    Location:
    NE OK
    I don't have any experience with New Hollands, but from your description, the two do not sound related. I'd check for a blown fuse or relay. Could be that something shorted or you lost a ground when messing with the gauge.
     
    Coy Lancaster likes this.