1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

pc50uu hydraulic problems

Discussion in 'Excavators' started by jeff45, Dec 25, 2014.

  1. jeff45

    jeff45 Active Member

    Joined:
    Jun 8, 2006
    Messages:
    39
    Location:
    quincy, ma
    Merry Christmas guys, I recently picked up a 96 komatsu pc50uu that has some hydraulic issues. It starts and runs fine but the only hydraulic function that works is one track and the blade. nothing else works at all, when you move the controls it doesn't make any noise like there is any strain on the hydraulic system or anything. the one track that does move has plenty of power and will spin the machine in circles and the blade is strong enough to lift the machine up. the previous owner said that the controls just suddenly stopped working one day. I would like to believe it is a simple safety switch but the track and blade still functions. Any idea what it could be? thanks in advance.
     
  2. apm

    apm Well-Known Member

    Joined:
    Apr 1, 2011
    Messages:
    170
    Location:
    Northeast Tennessee
    Do you know if you've got a PC50UU-1 or -2? I suspect if the year is accurate it's a -2.

    Greg
     
  3. jeff45

    jeff45 Active Member

    Joined:
    Jun 8, 2006
    Messages:
    39
    Location:
    quincy, ma
    it is a -2
     
  4. didden6

    didden6 Member

    Joined:
    Jun 26, 2013
    Messages:
    7
    Location:
    Belgiƫ
    have you checkt the servo lines ?
     
  5. jeff45

    jeff45 Active Member

    Joined:
    Jun 8, 2006
    Messages:
    39
    Location:
    quincy, ma
    I haven't checked anything to be honest. What are the servo lines?
     
  6. George catman

    George catman Active Member

    Joined:
    Jan 3, 2013
    Messages:
    44
    Location:
    Brisbane

    Hi Jeff,

    We had a problem once before that did take me some time to find at the time but behind the seat was a pattern control changer, small leaver assembly that had been bumped, it was halfway between backhoe and excavator pattern it had some strange faults that where quite hard to trace, worth a laugh when we found it though,

    Cheers