1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

New Holland C175

Discussion in 'Skid Steers' started by NCPIPELINE, Jun 3, 2014.

  1. NCPIPELINE

    NCPIPELINE Senior Member

    Joined:
    Mar 8, 2012
    Messages:
    444
    Occupation:
    The Fixer
    Location:
    Raleigh, NC
    Took hose off injection pump and the fuel pump is working. Took out fuel solenoid and still am not getting any fuel at injectors? Any ideas? Is it as simple as it needs a new injection pump?
     
  2. mikebramel

    mikebramel Senior Member

    Joined:
    Jul 15, 2012
    Messages:
    1,612
    Location:
    milwaukee
    Is there any pressure at the injectors with lines cracked