1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

Kx41-3 Starting Issue

Discussion in 'Excavators' started by Kris, Jul 4, 2011.

  1. Kris

    Kris Member

    Joined:
    Jul 4, 2011
    Messages:
    8
    Location:
    Florida
    All fluids are good,,machine was working fine,,, shut machine off , got off machine to due some stuff, got back on and went to start and would not start it does turn over and see fuel in filter just not firing up.:usa
     
  2. tool_king

    tool_king Senior Member

    Joined:
    Mar 29, 2010
    Messages:
    1,979
    Occupation:
    road mechanic owner
    Location:
    new jersey
    check battery ,starter and ground connections .check fuses for key switch.
     
  3. Kris

    Kris Member

    Joined:
    Jul 4, 2011
    Messages:
    8
    Location:
    Florida
    lookin for input on what might be wrong that it turns over but not startin up...
     
  4. Anto Modded

    Anto Modded Well-Known Member

    Joined:
    Mar 8, 2009
    Messages:
    143
    Occupation:
    Excavator Driver
    Location:
    Ireland
    Does it sound like it wants to start ? could it be air or the fuel pump or fuel filter maybe
     
  5. Kris

    Kris Member

    Joined:
    Jul 4, 2011
    Messages:
    8
    Location:
    Florida
    air filter is clean, Fuel filter is clean,,fuel pump is working,,,
     
  6. Haddy

    Haddy Well-Known Member

    Joined:
    May 6, 2011
    Messages:
    146
    Occupation:
    earthmoving contractor
    Location:
    Atiamuri New Zealand
    Try checking electric shut off value on fuel pump
     
  7. hitachi daft

    hitachi daft Active Member

    Joined:
    Jul 26, 2010
    Messages:
    26
    Occupation:
    plant fitter
    Location:
    scotland
    does it have a coded key
     
  8. tootalltimmy

    tootalltimmy Senior Member

    Joined:
    Aug 16, 2008
    Messages:
    397
    Location:
    Okanagan Falls B.C. Canada
    Emergency stop switch?
     
  9. tool_king

    tool_king Senior Member

    Joined:
    Mar 29, 2010
    Messages:
    1,979
    Occupation:
    road mechanic owner
    Location:
    new jersey
    Sorry Kris I thought you said it would not turn over my mistake.
     
  10. Kris

    Kris Member

    Joined:
    Jul 4, 2011
    Messages:
    8
    Location:
    Florida
    Thanks Everyone,,, It was the Injector solinoid shutoff,,,stuck in the shut off position,,,had to dismantle radiator side of machine for access. Thanks Again