1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

KVGT issue

Discussion in 'Excavators' started by Vetech63, Sep 12, 2019.

  1. Biglou101

    Biglou101 Member

    Joined:
    Feb 8, 2020
    Messages:
    7
    Location:
    Pennsylvania
    PC228USLC-10
     
  2. Biglou101

    Biglou101 Member

    Joined:
    Feb 8, 2020
    Messages:
    7
    Location:
    Pennsylvania
    PC228USLC-10
    Slightly different Than OP but I thought I could use most of the tips and Hints.
     
  3. funwithfuel

    funwithfuel Senior Member

    Joined:
    Mar 7, 2017
    Messages:
    2,678
    Occupation:
    Mechanic
    Location:
    Will county Illinois
    Still, all valid info, you are correct.
     
  4. Biglou101

    Biglou101 Member

    Joined:
    Feb 8, 2020
    Messages:
    7
    Location:
    Pennsylvania
    My pressure seems to be about 15 psi below minimum, is there a way to check the relief valve or will whole pump need to be removed.
     
  5. funwithfuel

    funwithfuel Senior Member

    Joined:
    Mar 7, 2017
    Messages:
    2,678
    Occupation:
    Mechanic
    Location:
    Will county Illinois
    You're above 125, yer fine. It's just control pressure to exercise the functions
     
  6. Vetech63

    Vetech63 Senior Member

    Joined:
    Aug 10, 2016
    Messages:
    2,080
    Location:
    Oklahoma
    Im glad FWF is here! Do everything he says as he is the resident expert on Komatsu stuff. JohnC. is good info also!
     
    mg2361 likes this.
  7. Vetech63

    Vetech63 Senior Member

    Joined:
    Aug 10, 2016
    Messages:
    2,080
    Location:
    Oklahoma
    Just to chime in...……...is there any current active fault codes on the monitor? It sounds like something else may be going on.
     
    mg2361 likes this.
  8. funwithfuel

    funwithfuel Senior Member

    Joined:
    Mar 7, 2017
    Messages:
    2,678
    Occupation:
    Mechanic
    Location:
    Will county Illinois
    Oh no, not even close, I'm just a fill in when John C is busy
     
    mg2361, John C. and Vetech63 like this.
  9. John C.

    John C. Senior Member

    Joined:
    Jun 12, 2007
    Messages:
    7,270
    Occupation:
    Machinery & Equipment Appraiser
    Location:
    Northwest
    You can give yourself more credit than that! I know a little about 15 year old stuff. I think you got the new stuff better than my old brain can sort through.
     
  10. funwithfuel

    funwithfuel Senior Member

    Joined:
    Mar 7, 2017
    Messages:
    2,678
    Occupation:
    Mechanic
    Location:
    Will county Illinois
    My noggin is stuck in Volvo operating systems. I find it makes it difficult to grasp how Komatsu works and Liebherr for that matter. Slowly coming around though.
    When it comes to engines and their operating systems, I try really hard to stay current .
     
    mg2361 likes this.
  11. John C.

    John C. Senior Member

    Joined:
    Jun 12, 2007
    Messages:
    7,270
    Occupation:
    Machinery & Equipment Appraiser
    Location:
    Northwest
    With engines, I’m not going to try any more.
     
    Ronsii likes this.
  12. DK88

    DK88 Senior Member

    Joined:
    Jan 19, 2011
    Messages:
    316
    Occupation:
    Field service tech.
    Location:
    Ontario
    you guys are good, typically the screen in the bottom of the rgr housing plugs easily, if its clean and good pressure from the boost oil pump, pull off the epc for vgt control and clean it well, and iirc correctly there is 2 screens under the block with the oil feed line on the tubro, the 125/140 engines plug them all the time. if no change change the turbo, ive changed a few for the helicopter noise your hearing.
     
  13. Biglou101

    Biglou101 Member

    Joined:
    Feb 8, 2020
    Messages:
    7
    Location:
    Pennsylvania
    Machine came back after working fine for a week, doing the same surge and had a fault for ca2554 exhaust back pressure sensor in range low. Surging again, replaced sensor and cleaned tube to manifold. Code came back for turbo position fault and machine continues to surge.