1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

John Deere 7775 Hour meter Issues

Discussion in 'Skid Steers' started by cb1978, May 13, 2022.

  1. cb1978

    cb1978 New Member

    Joined:
    Apr 29, 2022
    Messages:
    3
    Location:
    Minnesota
    I am curious if anyone has this on their display or has experience with it. My display show this number when on the hour meter.
    hour meter.jpg
    I thought this was the current hours on the machine, however, the number counts up while running. When the machine is shut off, it resets back to this number. I have no idea how many hours are actually on the machine. When initially started, everything lights up as it should, there are no burned out of "dead" digits. My manual says if there is issues with the hour meter and the oil pressure system is fine, it would need to be reset by DTAC, which I'm assuming is John Deere. My machine is a 1997 JD 7775. Thanks in advance.
     
  2. mg2361

    mg2361 Senior Member

    Joined:
    Jul 5, 2016
    Messages:
    3,374
    Occupation:
    Equipment Mechanic/Technician
    Location:
    Pennsylvania
    Welcome to HEF CB;)!

    I have never seen that one. First thing I would try is to disconnect the battery negative cable for 5 minutes. Then reconnect. See if that works.

    When you sit in the seat does the following occur (with the service/run switch in the run position)?
    1. All lights should light
    2. Characters should show all eights (8888.8)
    3. Park Brake and seat light should flash
    4. Buckle the seat belt, seat belt light will go out and Park Brake will keep flashing
    5. Turn ignition key to "on" position. Park Light will go out.
    6. Press "Arrow" switch to change the monitored function and character display. Does the display change?
     
    Vetech63 likes this.
  3. cb1978

    cb1978 New Member

    Joined:
    Apr 29, 2022
    Messages:
    3
    Location:
    Minnesota
    My machine does everything you asked. Pressing the arrow does change the function, i.e. rpms, battery, temp, etc. This is in the run and service position.
     
  4. mg2361

    mg2361 Senior Member

    Joined:
    Jul 5, 2016
    Messages:
    3,374
    Occupation:
    Equipment Mechanic/Technician
    Location:
    Pennsylvania
    Hmmm. Don't have an answer for that one. Maybe a voltage spike or something. Struck by lightning? Welding on the machine?

    I PM'd you.
     
  5. cb1978

    cb1978 New Member

    Joined:
    Apr 29, 2022
    Messages:
    3
    Location:
    Minnesota
    Thank you. Nothing since I've had it. There appears to be some welding that happened previously.