1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

John deere 544j no power at idle lots at rough idle.

Discussion in 'Wheel Loaders' started by Wayne McNeil, Jun 22, 2019.

  1. Wayne McNeil

    Wayne McNeil Member

    Joined:
    Jun 21, 2019
    Messages:
    5
    Location:
    Port aux basques nl
    I have a 544j John deere loader it got little power but idles beautifully shut it off then restart it and it idles rough but lots of power. What's with that?
     
  2. heymccall

    heymccall Senior Member

    Joined:
    Feb 20, 2007
    Messages:
    1,257
    Location:
    Monroeville, Pa
    Which engine?
    Rotary injection pump or common rail injection?
    When did symptoms start? Right after changing fuel filters?
     
  3. Wayne McNeil

    Wayne McNeil Member

    Joined:
    Jun 21, 2019
    Messages:
    5
    Location:
    Port aux basques nl
    Common rail. Seems to have gotten worst after filter change. Seems like to me either air or collapse line. At a lost for now.
     
  4. Wayne McNeil

    Wayne McNeil Member

    Joined:
    Jun 21, 2019
    Messages:
    5
    Location:
    Port aux basques nl
    Why would there be a difference in pumps or mechanical I jections.
     
  5. Bls repair

    Bls repair Senior Member

    Joined:
    Jan 21, 2017
    Messages:
    821
    Occupation:
    Equipment operator,mechanic
    Location:
    S E Pa
    Where I use to work we had a JD loader that act up every now and then. We would shut it off then turn off master switch ,wait 30 sec. then start . That would usually help
     
  6. Wayne McNeil

    Wayne McNeil Member

    Joined:
    Jun 21, 2019
    Messages:
    5
    Location:
    Port aux basques nl
    Tried that hoping it would reset the system. No go. What I find strange is this unit idles beautifully but lacks power. Shut it off then restart it and itll idle rough yet power is all there. I am baffled with this one unless theres a sensor somewhere acting up and the restart bypasses it.
     
  7. heymccall

    heymccall Senior Member

    Joined:
    Feb 20, 2007
    Messages:
    1,257
    Location:
    Monroeville, Pa
    Because my 544Js have mechanical injection.
     
    Last edited: Jun 23, 2019