1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

Jlg 40H issues

Discussion in 'Other Construction/Demolition Equipment' started by rbcanaday, Mar 20, 2022.

  1. rbcanaday

    rbcanaday Well-Known Member

    Joined:
    Mar 11, 2015
    Messages:
    66
    Location:
    Walterboro, SC
    Have a Jlg 40h with ford 423 motor. Rebuilt carb but still doesn’t seem to idle just right. Will fire right up 9 out of 10 times but every so often it won’t crank for anything. Takes numerous starts to get an attemp to fore them runs crappy for 2-3 mins before leveling out.
    Carb rebuilt, new fuel pump, new fuel shutoff solenoid. I have a clear inline filter just after gas tank. Filter never fills with fuel. Not sure why. Could that mean carb isn’t getting enough fuel?
    also machine doesn’t want to shut down unless I kill master switch. It wants to diesel if shut off normal way. I replaced fuel shutoff but it’s still doing it.

    Any thoughts or advice?
     
  2. OFF

    OFF Senior Member

    Joined:
    Sep 30, 2009
    Messages:
    940
    Occupation:
    HD Mechanic
    Location:
    Alberta, Canada
    Those clear plastic fuel filters very often don't seem to fill up. The engine doesn't care, they run anyway.

    Dieseling on a gasoline engine is a function of idle speed. Have you maybe got the idle speed set using the screw on the throttle plate rather than letting the governor do it? Does the power to the fuel shutoff stop when you turn off the ignition ?
     
  3. rbcanaday

    rbcanaday Well-Known Member

    Joined:
    Mar 11, 2015
    Messages:
    66
    Location:
    Walterboro, SC
    Maybe you are right about that clear filter. It seems to run ok for most part.
    The idle screw could be set wrong. I had a mechanic help me rebuild and setup the carb. He is top notch mechanic but he could have it adjusted wrong. I’m gonna hook a light to the fuel shut off and make sure it does loose power. Will update soon.
     
    OFF likes this.