1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

JD 548G 4000 series winch

Discussion in 'Forestry Equipment' started by EliteEquipmentRepair, Nov 20, 2021.

  1. EliteEquipmentRepair

    EliteEquipmentRepair Member

    Joined:
    Oct 28, 2021
    Messages:
    10
    Location:
    Indiana
    Can anyone tell me if the freespool drag adjustment screw/brake pad should be wet with oil? Trying to determine from parts break downs if that should have oil in the area but i cant tell. Its a total pain to pull just to inspect for myself to find out.
     
  2. mg2361

    mg2361 Senior Member

    Joined:
    Jul 5, 2016
    Messages:
    3,027
    Occupation:
    Equipment Mechanic/Technician
    Location:
    Pennsylvania
    I would think not, but my memory on winches is failing:eek:. Any oil leaking around the drum? I would think the seals below would be the issue.



    Winch Seals.png
     
  3. EliteEquipmentRepair

    EliteEquipmentRepair Member

    Joined:
    Oct 28, 2021
    Messages:
    10
    Location:
    Indiana
    Hey, thanks for the reply. Shortly after i made this thread I got it figured out and forgot i posted on here. There isnt supposed to be oil there so ill be pulling the winch and drum