1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

it28g has no power past 1400rpm

Discussion in 'Tool Carriers' started by cummins1989, May 14, 2015.

  1. cummins1989

    cummins1989 Member

    Joined:
    May 14, 2015
    Messages:
    5
    Location:
    connecticut
    Hey im new to this site my name is dave. I have an 04 it28g. Serial # cpt07384e engine is a 3056e and anything past 1400rpm the engine skips alot and has no power at all. I was thinking a fuel problem( new fuel filters) but almost seems electrical. Any input would be a huge help.
     
  2. cummins1989

    cummins1989 Member

    Joined:
    May 14, 2015
    Messages:
    5
    Location:
    connecticut
    Sorry no e on the back of that serial number
     
  3. cummins1989

    cummins1989 Member

    Joined:
    May 14, 2015
    Messages:
    5
    Location:
    connecticut
    Also it idles fine
     
  4. cummins1989

    cummins1989 Member

    Joined:
    May 14, 2015
    Messages:
    5
    Location:
    connecticut
    For anyone wondering it was sludge in the fuel tank
     
  5. D11RCD

    D11RCD COPPA Member

    Joined:
    Aug 20, 2008
    Messages:
    161
    Occupation:
    school
    Location:
    Australia
    Sludge in the tank. Cheers for clearing that up. Hope you replaced your fuel filters after you cleaned the tank :)
     
  6. cummins1989

    cummins1989 Member

    Joined:
    May 14, 2015
    Messages:
    5
    Location:
    connecticut
    Turns out that its still not running right. Im going ro try new fuels lines they might be callapsing. Anyone know what the vacuum should be on the suction side of the liftpump? Or fuel pressures on the other side?