1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

Hitachi zx225uslc throttle not working

Discussion in 'Excavators' started by Martin Canuel, Nov 18, 2019.

  1. Martin Canuel

    Martin Canuel Active Member

    Joined:
    Nov 16, 2019
    Messages:
    29
    Location:
    Prince George, British Columbia
    Did a relearn did not solve the issue with not being able to turn off with key.Throttle works however
     
  2. excavator

    excavator Senior Member

    Joined:
    Oct 16, 2006
    Messages:
    883
    Location:
    Pacific North West
    I've had them with a bad diode in the alternator not allowing the battery relay to turn off but they were all dash 5 or earlier. I also had a ZX230 that would not shut off with the key, it had a small wiring fire down behind the batteries that melted all the wires in the harness together. The amazing thing was it did not blow any fuses.
     
  3. Martin Canuel

    Martin Canuel Active Member

    Joined:
    Nov 16, 2019
    Messages:
    29
    Location:
    Prince George, British Columbia
    Interesting.. so this diode in the alternator i assume is not replaceable/serviceable.. has to be replaced with the alternator?
    So check harness to the alternator then?
     
  4. Martin Canuel

    Martin Canuel Active Member

    Joined:
    Nov 16, 2019
    Messages:
    29
    Location:
    Prince George, British Columbia
    Ive read that welding on the machine can cause alternator diodes to get fried. That being said we just welded catwalks on the machine and a thumb prior to that, we used the night switch as our battery disconnect. Maybe the 2 events are related..
     
    DB2 likes this.
  5. LACHAU

    LACHAU Well-Known Member

    Joined:
    Aug 11, 2009
    Messages:
    157
    Location:
    VIETNAM HCMCity
    There are 2 simple ways (very...very...very easy to solve the problem).

    ZX225US GOVERNOR.png

    ZX225US GOVERNOR 2.png
     
  6. Volvomad

    Volvomad Senior Member

    Joined:
    Jul 14, 2011
    Messages:
    251
    Location:
    Ireland
    Just wondering when you go to turn off does the engine speed drop any ?
     
  7. Martin Canuel

    Martin Canuel Active Member

    Joined:
    Nov 16, 2019
    Messages:
    29
    Location:
    Prince George, British Columbia
    I was finally able to get someone to shut of the machine while i watched the servo motor. When shutting down the engine you can hear rpm drop/ sputter a bit to a lower rpm. Watching the actual motor it barely actuates the throttle when shutting it down. Iam going to adjust the throttle cable some more manually and see if that solves my issue.
     
  8. Martin Canuel

    Martin Canuel Active Member

    Joined:
    Nov 16, 2019
    Messages:
    29
    Location:
    Prince George, British Columbia
    OK adjusted the throttle cable while machine was running and took the idle right down to almost a sputter, then ithgtened it up and used key to turn off, barely made the rpm drop when i hit the key off.. engine relearn ? also when i had the servo motor disconnected initially there was about a inch of play in the throttle cable,. when i attach the servo to the arm do i pull out all the slack and tighten it>?
     
  9. Volvomad

    Volvomad Senior Member

    Joined:
    Jul 14, 2011
    Messages:
    251
    Location:
    Ireland
    If there is an inch of freeplay in the system (not moving injection pump lever) I would think that is your problem
     
  10. Martin Canuel

    Martin Canuel Active Member

    Joined:
    Nov 16, 2019
    Messages:
    29
    Location:
    Prince George, British Columbia
    Well after all of that, replace servo motor, pulling interior dash apart to test wiring, testing all the sensors, took your advice and replaced the throttle cable and wouldnt you know it a new throttle cable from servo to inj. pump fixed all my issues!!! I do thank all of you for the trouble shooting help i truly appreciate it and it actually helped me learn alot about my machine.
     
    mg2361 and LACHAU like this.
  11. Martin Canuel

    Martin Canuel Active Member

    Joined:
    Nov 16, 2019
    Messages:
    29
    Location:
    Prince George, British Columbia
    Well guys its doing the exact same thing again
    1- wont shut off with key
    2- dr.zx wont communicate
    3- no servo sound or motion with key on
    4- must use manual throttle kill to turn off machine
    5- servo motor, throttle cable have been replaced.
     
  12. Martin Canuel

    Martin Canuel Active Member

    Joined:
    Nov 16, 2019
    Messages:
    29
    Location:
    Prince George, British Columbia
    None whatsoever, when i turn on the key generally you can her the servo motor do a adjustment of some sort, when i have this issue it makes no sound with key on
     
  13. Martin Canuel

    Martin Canuel Active Member

    Joined:
    Nov 16, 2019
    Messages:
    29
    Location:
    Prince George, British Columbia
    We replaced the throttle cable thought it solved the issue, was temporary. now back to square one doing the same thing again
     
  14. Couger Chris

    Couger Chris New Member

    Joined:
    Saturday
    Messages:
    1
    Location:
    Canada
    Hi, we are going through the same problems on a 225. Did you win?