1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

Grove RT60S drives, then does not, then drives again

Discussion in 'Cranes' started by ichudov, Oct 26, 2018.

  1. tractormech

    tractormech Well-Known Member

    Joined:
    Feb 19, 2015
    Messages:
    68
    Location:
    florida
    Ichudov-I have an old Grove book with all the hydraulic schematics if you need help with anything. I had two old RT63S machines I kept up and I believe the 60 is in there too.
     
  2. tractormech

    tractormech Well-Known Member

    Joined:
    Feb 19, 2015
    Messages:
    68
    Location:
    florida
    There is a suction hose from the bevel gear housing to the converter that may be collapsed or has a flap inside sucking shut...the belly pan has to be dropped for access
     
  3. ichudov

    ichudov Senior Member

    Joined:
    Oct 18, 2014
    Messages:
    422
    Location:
    United States
    The problem, I think, was lack of oil, we added trans oil and it seems to be okay for now. That was the right suggestion! Thanks to all!!!
     
  4. tractormech

    tractormech Well-Known Member

    Joined:
    Feb 19, 2015
    Messages:
    68
    Location:
    florida
    Sorry- I was replying to the guy with the D7 issue...I see you got it going