1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

Ginie 34/22 bi

Discussion in 'Other Compact Equipment' started by Hinos, Aug 13, 2020.

  1. Hinos

    Hinos New Member

    Joined:
    Aug 11, 2020
    Messages:
    2
    Location:
    Kingwood
    I'm having problems with my ginie 34/22bi, boom lift,suddenly the platform mechanisms and the drive steering don't work, when I press the steering or the platform command button I can here the pump motor working, also I see pressure in the hoses but no movement, I did exchange the solenoid valves but they are fine on other mechanisms, the steering works wen I press the boom up simultaneously.
    The platform doesn't move.
    I disconnect the hoses from the platform rotator and oil squirt from both hoses even wen I press any other commands...it's like the pressure it's fighting against each other??
    Are this solenoids supposed to close the oil flow completely wen not in use??
    Please help.