1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

Genie Z60/34 boom lift

Discussion in 'Other Construction/Demolition Equipment' started by tool_king, Oct 11, 2010.

  1. tool_king

    tool_king Senior Member

    Joined:
    Mar 29, 2010
    Messages:
    1,153
    Occupation:
    road mechanic owner
    Location:
    new jersey
    I have here a Genie Z60/34 boom lift serial number Z60-3551 with 2370 hours on it. That somedays the swing is good in either directions .Other days it so slow in either directions.Anyone have any ideas.
     
  2. willie59

    willie59 Super Moderator

    Joined:
    Dec 21, 2008
    Messages:
    11,885
    Occupation:
    Service Manager
    Location:
    Knoxville TN
    but telescope and boom up/dwn funtions are fine? The first thing I would try would be switch the wiring for the swing functions at the joystick with the telecsope function. It's a 4 direction controller. Forward and back operates telescope, left and right operates swing. Switch the wiring connections so the swing is forward and back, and telescope is left and right. If the telescope now starts to malfunction, then the circuit card or potentiometer of that part of the 4 way controller is bad.
     
  3. tool_king

    tool_king Senior Member

    Joined:
    Mar 29, 2010
    Messages:
    1,153
    Occupation:
    road mechanic owner
    Location:
    new jersey
    Pual that is what I thought to. I am still working on that Gove lift .I need a breakdown on that area were the power module is were the ground cables come from the motor .I have to call your friend at Bestline and see if he can send me copy of it.
     
  4. willie59

    willie59 Super Moderator

    Joined:
    Dec 21, 2008
    Messages:
    11,885
    Occupation:
    Service Manager
    Location:
    Knoxville TN
    Eric has been very helpful to me over the years, he knows his s#*t. Genie lifts are a different animal. Usually not too bad to work on. There's a number of things that can cause your problem on that machine, but if all other boom functions work proper, including telescope, I think it's either going to be a problem with that part of the 4 way controller or a problem in the wiring from top to bottom. Switching the connections to the 4 way controller is the first thing I would do.
     
  5. z60/34

    z60/34 New Member

    Joined:
    Nov 17, 2010
    Messages:
    3
    Location:
    iowa
    hi i am a new member .. soory to some what hi jack your post but i have to post 3 times to be able to post .
    i also have a z60/34 and am having problems with the 4 x 4
     
  6. BGG

    BGG Member

    Joined:
    Sep 15, 2011
    Messages:
    9
    Location:
    Western Canada
    I,m new here too. I,m having problems with my Z60. I, intermitently, loose all my joystick functions( all three joysticks) The toggle switches all still work. To get the unit working again, I shut the machine down and restart it, and it works. I,m not getting any codes on the board, and I have tried to recalibrate all the joysticks. I checked the ground connection on the side of the box, and it,s ok. Not sure where to look now.
     
  7. Robertdiesel

    Robertdiesel Member

    Joined:
    Jan 5, 2016
    Messages:
    10
    Location:
    Fort Worth
    Wow where's the genie guru. I need help too.
     
  8. pitse

    pitse New Member

    Joined:
    Jan 31, 2018
    Messages:
    1
    Location:
    philadelphia
    need serious help-my genie 2008 Z60/34 serial # Z6008-9237 has cracked all 4 existing drive hubs and 1 new for a total of 5 drive hubs, the casting cracks I'll assume for over pressuring
    check vlv was also installed as repair shop said he found problem but didn't, this machine now sits till i find a real solution, i'm not buying another drive hub until i know whats making the cast crack and leak!
    please any help will be much appreciated-
     
  9. Johndoe

    Johndoe Active Member

    Joined:
    Sep 20, 2016
    Messages:
    26
    Location:
    USA

    You are pressurizing your drive motors' CASE DRAIN circuit. this will cause the shaft seal on the drive motors to fail. Hydraulic fluid will enter and pressurize the torque hub.
    The case drains all tie together then return to the hydraulic tank. Find and repair the restriction Then replace the seals on all four drive motors.