1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

Ford NH 655C NO FWD..NO REVERSE

Discussion in 'Tractor/Loader/Backhoes' started by Robertjohn, Nov 15, 2022.

  1. Robertjohn

    Robertjohn New Member

    Joined:
    Nov 15, 2022
    Messages:
    3
    Location:
    Tx
    Just got a 655C, USED Two days. Backhoe & Bucket work great. Suddenly..no Fwd or Rev. Checked three fuses...all good. Ckd continuity on shuttle push button...good.
     
  2. aighead

    aighead Senior Member

    Joined:
    Apr 25, 2019
    Messages:
    2,138
    Location:
    Dayton, OH
    The most basic answer I have, since I'm not smart enough otherwise, is is your clutch cutoff button stuck on the loader? Is that what you are calling the shuttle push button I'm assuming that's the one on the gear shift lever? I don't know if I have the correct name for it.

    On my NH lb75b the button on the loader lever gets stuck pretty regularly. The machine will rev but not go anywhere. I've got to kind of press it and slide my thumb of to the side to get it unstuck, like the plastic is just binding up or something. I could try a little lube in there maybe...
     
    NH575E likes this.