1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

Deere 755c issue

Discussion in 'Track Loaders' started by Oliver182, Jan 10, 2022.

  1. Oliver182

    Oliver182 Well-Known Member

    Joined:
    Dec 18, 2008
    Messages:
    85
    Location:
    Iowa
    Had a indicator light come on in my 755c series 2 machine this afternoon. It’s the transmission oil pressure indicator light. Had been operating the machine for a half hour or so and received a phone call so went to idle. When finished with the call noticed the light on. When I would rev up the machine it would go away but return on when at idle. Parked it for the day planning on replacing filter in morning. When I looked in manual it describes it further as “transmission hydrualic replenishing oil pressure indicator” call dealer it says. Dealer says it might have been the colder temp today( 25ish) but I had been operating the machine for half hour or so. Any ideas where to start besides filter? I have had a couple hydrualic hose failures lately so have pretty much replaced the oil in the last 50 hours. I did notice right before the light came on in a hard push it kinda stuttered a bit but i assumed it was from spinning on the frozen ground but maybe it wasn’t. Thanks for any help
     
  2. mg2361

    mg2361 Senior Member

    Joined:
    Jul 5, 2016
    Messages:
    3,593
    Occupation:
    Equipment Mechanic/Technician
    Location:
    Pennsylvania
    Serial number? Picture of the light in question?
     
    BigWrench55 likes this.
  3. Oliver182

    Oliver182 Well-Known Member

    Joined:
    Dec 18, 2008
    Messages:
    85
    Location:
    Iowa
    LU755CX006265 serial number
    Attached photo
     

    Attached Files:

  4. mg2361

    mg2361 Senior Member

    Joined:
    Jul 5, 2016
    Messages:
    3,593
    Occupation:
    Equipment Mechanic/Technician
    Location:
    Pennsylvania
    Do you have pressure gauges? Charge pressure needs to be checked to see if there is in fact a pressure issue or a sensor issue.
     
    Vetech63 and BigWrench55 like this.
  5. Oliver182

    Oliver182 Well-Known Member

    Joined:
    Dec 18, 2008
    Messages:
    85
    Location:
    Iowa
    Checked charge pressure. About 45 degrees out today let it run for 20 minutes. 245-250psi. Light stays on at idle and initially goes out when rev it up but then light comes back. It actually flashes on/off super fast. Pressure about 250 at higher rpms. Going to replace filter in morning and check again.
     
  6. mg2361

    mg2361 Senior Member

    Joined:
    Jul 5, 2016
    Messages:
    3,593
    Occupation:
    Equipment Mechanic/Technician
    Location:
    Pennsylvania
    Minimum pressure is supposed to be 232 psi. Yes, change your filter first, if that does not resolve your light issue then it sounds like a pressure switch is going wonky.
     
    Cat977, Vetech63 and BigWrench55 like this.
  7. Oliver182

    Oliver182 Well-Known Member

    Joined:
    Dec 18, 2008
    Messages:
    85
    Location:
    Iowa
    Replaced filter today and started with gauge on again. Still the warning light and pressure at 245-250. Ordered pressure switch to replace and hope that does it. Thanks for help so far.
     
  8. Oliver182

    Oliver182 Well-Known Member

    Joined:
    Dec 18, 2008
    Messages:
    85
    Location:
    Iowa
    Replaced pressure switch and that took care of the issue. Thanks for the help mg2361
     
    Cat977, mg2361 and BigWrench55 like this.