1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

cat cb214e dual drum roller issue

Discussion in 'Rollers' started by KatoK, Jun 10, 2019.

  1. KatoK

    KatoK New Member

    Joined:
    Jun 10, 2019
    Messages:
    3
    Location:
    Ontario, Canada
    Having an issue with our roller. It seems as though it won't come out of the parking brake. When the parking brake button is pulled up ( released) it is refusing to move forward or back. I can see the parking brake light is working as designed as i can see it go on/off as i release the brake, but the roller wont move.
    Anyone have any tips. Tried to find the manuals online but wasn't able to.
     

    Attached Files:

  2. heymccall

    heymccall Senior Member

    Joined:
    Feb 20, 2007
    Messages:
    1,140
    Location:
    Monroeville, Pa
    Mine has a seat sensor, too. Worth checking/ bypassing.
     
  3. KatoK

    KatoK New Member

    Joined:
    Jun 10, 2019
    Messages:
    3
    Location:
    Ontario, Canada
    i don't think this machine has that..i have seen it move when not sitting onit...This problem did happen before a few times, but would start working magically after a little while. Not so lucky this time around.
     
  4. Vetech63

    Vetech63 Senior Member

    Joined:
    Aug 10, 2016
    Messages:
    1,415
    Location:
    Oklahoma
    Some park brake systems also have a solenoid valve that prevents swash plate control pressure when the park brake is engaged. I see those mostly on the Ingersol Rand rollers so I am not sure if yours has that feature. A wiring schematic could be of great help in determining your problem.
     
    mg2361 likes this.
  5. heymccall

    heymccall Senior Member

    Joined:
    Feb 20, 2007
    Messages:
    1,140
    Location:
    Monroeville, Pa
    My cb224c did not have a seat sensor, but, it was capable.
    The harness ran along side the spray tank under the seat, and had a jumper (dummy) plug instead of a seat sensor. That "unused" harness rubbed through and gave the same symptoms. And that was 2 model generations before yours.
     
    mg2361 likes this.
  6. KatoK

    KatoK New Member

    Joined:
    Jun 10, 2019
    Messages:
    3
    Location:
    Ontario, Canada
    Just had a mechanic look at it..he thinks it is the parking brake solenoid. will replace that and hope for the best.