1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

Cat 320 DL No Start Condition 6.4 L Acert

Discussion in 'Excavators' started by Avidoutdoors, Apr 28, 2022.

  1. Avidoutdoors

    Avidoutdoors Member

    Joined:
    Jun 24, 2021
    Messages:
    17
    Location:
    Iola,Tx
    Crank no start condition, have fuel to the pump but no fuel rail pressure. Don't appear to have voltage at fuel solenoid on the pump. What is specified voltage? Does anyone have a service manual for this machine? CAT0320DVPHX00929
     
  2. heymccall

    heymccall Senior Member

    Joined:
    Feb 19, 2007
    Messages:
    3,797
    Location:
    White Oak, Pa
    If your proficient in using the monitor service menus, check to see if the RPMs are indicated while cranking. I believe that they are under "Status", then "Inputs".

    My 314D (C4.4, same electronics minus 2 cylinders) lost the crankshaft sensor (no codes) and cranked but never turned on the fuel. Zero RPMs were shown while cranking.
     
    anuradha, John Shipp and nowing75 like this.
  3. nowing75

    nowing75 Senior Member

    Joined:
    Aug 5, 2009
    Messages:
    805
    Location:
    coatesville indiana
    If you want to send me your email i could send you some info> i take it you have et and are seeing no rail pressure?
     
    anuradha and John Shipp like this.
  4. Avidoutdoors

    Avidoutdoors Member

    Joined:
    Jun 24, 2021
    Messages:
    17
    Location:
    Iola,Tx
    I do have rpm signal
     
  5. Avidoutdoors

    Avidoutdoors Member

    Joined:
    Jun 24, 2021
    Messages:
    17
    Location:
    Iola,Tx
    eddiebakemeier@yahoo.com Thanks