1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

Case CX130B running rough and shutting down

Discussion in 'Excavators' started by Champwise, Nov 11, 2019 at 1:33 AM.

  1. Champwise

    Champwise Member

    Joined:
    Aug 20, 2019
    Messages:
    10
    Location:
    australia
    Hi guys,

    The engine starts up, runs rough and shuts down. This has beenan intermittent issue for some time and is now making the machine inoperable.

    It has a 0193 fault code present on the console but I don't have any info on case fault codes.

    Any service/part manuals and schematics for this machine would also be appreciated.

    The machine serial number is 130K5N8SAD1114.

    Thanks

    Sam
     
  2. LACHAU

    LACHAU Well-Known Member

    Joined:
    Aug 11, 2009
    Messages:
    89
    Location:
    VIETNAM HCMCity
    Please see attached file for more detail of this fault code.
    000.png
     

    Attached Files:

    Champwise and GregsHD like this.
  3. Champwise

    Champwise Member

    Joined:
    Aug 20, 2019
    Messages:
    10
    Location:
    australia
    Thanks mate, you're the case guru.
     
  4. Champwise

    Champwise Member

    Joined:
    Aug 20, 2019
    Messages:
    10
    Location:
    australia
    Hey mate. So I've unplugged the pressure sensor and measured voltages across all the pins on on the plug. After doing that I now have 2 other fault codes showing, 0089 and 0087.

    From what I understand, voltage above normal means the sensor is unplugged and the ecm is at pullup voltage. Could this code also point to a faulty sensor?

    My voltages across each pin are the following:
    Unplugged:
    Blueyellow to orange: 4.89v
    Blueyellow to blue: 5v
    Orange to blue: 0v

    Plugged in:
    Blueyellow to orange: 1v
    Blueyellow to blue: 5v
    Orange to blue: 0v

    Also can anyone name the connector type in the picture and where to buy them in australia?

    Thanks
     

    Attached Files: