1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

Case 586E No Forward

Discussion in 'Forklifts/Telehandlers' started by DougC, Apr 4, 2017.

  1. DougC

    DougC Member

    Joined:
    Apr 4, 2017
    Messages:
    8
    Occupation:
    Equipment Maintenance Mechanic
    Location:
    Salisbury MD
    I'm new here and haven't found information on any other thread for this exact issue. Equipment number is 17019956. Not sure if that helps any. I have a Case 586E forklift and it has reverse but no forward gears. Forward won't really do anything in any of the 4 gears. Fluid is not low. The linkage is not broken or disconnected. I can see it moving and the solenoid moving when shifted from forward to reverse and vice versa. Any ideas on what I can do next to diagnose this issue, please? Thanks.
     
  2. sheepfoot

    sheepfoot Senior Member

    Joined:
    Feb 17, 2008
    Messages:
    1,259
    Location:
    wilmington nc
    You can use any thread that deals with a 580C/D/E/and phase 1 K series Your 584/585/586 C/D/E all use the same shuttle. The spring washer is more than likely broken in the forward clutch area. This requires the shuttle to be pulled out to be repaired. It will take a good hour to remove the unit and a little longer if it is 4WD. A good day cleaning,checking and replacing parts as needed. Converter and charge pump checked for wear signs. You may only need a gasket kit and a spring washer but the rebuild kits with the clutches are not that bad cost wise. They are a Borg Warner F/R unit and are used in many makes of const equipment. Joseph Industries, Broken tractor, and others sell the kits along with case
     
  3. DougC

    DougC Member

    Joined:
    Apr 4, 2017
    Messages:
    8
    Occupation:
    Equipment Maintenance Mechanic
    Location:
    Salisbury MD
    Thanks for your help sheepfoot. Still learning on these old Case monsters I have to work with here.