1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

Bomag BW11RH Cutting off intermittently

Discussion in 'Rollers' started by Greasyfitting, Aug 4, 2022.

  1. Greasyfitting

    Greasyfitting Member

    Joined:
    Sep 3, 2021
    Messages:
    19
    Location:
    Savannah, GA
    Worked on BW11RH today it would run fine but will idled down and cut off and the screen just says CTO I have never seen that before. The hydraulic filter blocked light now comes on as well causing it to shut down. I took the filter off the the oil is clean no gunk, or metal the O-ring on the hydraulic filter housing is damaged. I unplugged the sensor and jumped it the light still comes on. Any insight would be appreciated!
     
  2. mg2361

    mg2361 Senior Member

    Joined:
    Jul 5, 2016
    Messages:
    3,605
    Occupation:
    Equipment Mechanic/Technician
    Location:
    Pennsylvania
    Don't know if I can be of any good, but post a serial number please.