1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!
  2. ALL NEW MEMBERS READ THIS FIRST!! Thank you for joining Heavy Equipment Forums! If you are new to forums we communicate with "Threads", please search our threads to see if your topic may have already been answered and if not then click "Post New Thread" in the appropriate forum. This will allow all of our members to see your question and give you the best chance to be answered. After you've made a number of posts you will graduate to Full Member status where you'll see a few more privileges. Following these guidelines will help make this the best resource for heavy equipment on the net. Thanks for joining us and I hope you enjoy your stay!!

2014 e35i 600 hours stalls and low power and no x change.

Discussion in 'Excavators' started by Tomcat955, Jul 25, 2022.

  1. Tomcat955

    Tomcat955 Member

    Joined:
    Sep 12, 2021
    Messages:
    13
    Location:
    Illinois
    I’ve got a bobcat e35i 2014 that i bought with 600 hours that was involved in a roll over. The machine sat for a couple years. I got it running but the x change pins don’t work. It like disables the machine when the button is pressed as if you opened the driver arm rest to step out. My other large issue is that it seems sluggish. If you raise or drop the boom full speed will stall the engine out. Try to take a turn to hard stall out. I changed the 2 hydraulic filters all looked clean the fluid looked clean. The rabbit button does not seem to do much change either. Steve suggested the 2spd solenoid just looking for as much input as possible