1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

2012 John Deere 310J

Discussion in 'Tractor/Loader/Backhoes' started by Robert Rdz, May 16, 2019.

  1. Robert Rdz

    Robert Rdz Member

    Joined:
    May 16, 2019
    Messages:
    9
    Location:
    Corpus
    Hello, I was wondering if any could please help me out. I have a 2012 John Deere 310J that once it gets to operating temp. and we engage the parking brake it will not release. We have changed out the sensor on top of the rear diff and the parking brake switch and we continue to have the same problem. Does anyone have an idea of what else might be wrong with this tractor.
     
  2. mg2361

    mg2361 Senior Member

    Joined:
    Jul 5, 2016
    Messages:
    582
    Occupation:
    Equipment Mechanic
    Location:
    Pennsylvania
    Welcome to HEF Robert. Check your transmission fluid level. Will it disengage with the engine revved up?
     
  3. Robert Rdz

    Robert Rdz Member

    Joined:
    May 16, 2019
    Messages:
    9
    Location:
    Corpus
    Not 100% sure, I will check it out and get back to you. Thanks
     
  4. Robert Rdz

    Robert Rdz Member

    Joined:
    May 16, 2019
    Messages:
    9
    Location:
    Corpus
    So transmission level is good and we just tried reving the engine and that didn’t work.
     
  5. Robert Rdz

    Robert Rdz Member

    Joined:
    May 16, 2019
    Messages:
    9
    Location:
    Corpus
    Transmission level is good and we tried revving the engine and that didn’t work.
     
  6. mg2361

    mg2361 Senior Member

    Joined:
    Jul 5, 2016
    Messages:
    582
    Occupation:
    Equipment Mechanic
    Location:
    Pennsylvania
    With Deere as with Cat machines, serial numbers are important for correct information. Sounds like the PB solenoid has an issue. Any codes pop up? When unit is warmed up and acting up I would suggest checking the resistance of the PB Solenoid to see if that is your issue. Below is the location and the spec.

    310J Y7 PB Solenoid.png 310J Sol Spec.png
     
  7. Robert Rdz

    Robert Rdz Member

    Joined:
    May 16, 2019
    Messages:
    9
    Location:
    Corpus
    Thanks I will check that out this morning, so I am out in a ranch if the solenoid is no good can I change it out with Y10? Just to load it on the trailer?
     
  8. Robert Rdz

    Robert Rdz Member

    Joined:
    May 16, 2019
    Messages:
    9
    Location:
    Corpus
    Here is the SN 1T0310JXTCD217062
     
  9. mg2361

    mg2361 Senior Member

    Joined:
    Jul 5, 2016
    Messages:
    582
    Occupation:
    Equipment Mechanic
    Location:
    Pennsylvania
    Yes you can. Y10 is for the diff lock.
     
  10. Robert Rdz

    Robert Rdz Member

    Joined:
    May 16, 2019
    Messages:
    9
    Location:
    Corpus
    Thank you I will keep you posted! We are on one side of the ranch right now should have some time this afternoon to try it out.
     
  11. Robert Rdz

    Robert Rdz Member

    Joined:
    May 16, 2019
    Messages:
    9
    Location:
    Corpus
    So the solenoid has a reading of 10.8.
     
  12. Robert Rdz

    Robert Rdz Member

    Joined:
    May 16, 2019
    Messages:
    9
    Location:
    Corpus
    My bad the parking brake solenoid was reading 4.5 change it out and it fixed the issue. Thanks for all the help!
     
  13. mg2361

    mg2361 Senior Member

    Joined:
    Jul 5, 2016
    Messages:
    582
    Occupation:
    Equipment Mechanic
    Location:
    Pennsylvania
    Glad to hear it and thanks for the update;).