1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

MF 240 - farmhand loader problems

Discussion in 'Tractor/Loader/Backhoes' started by jeeperguytj, Aug 4, 2009.

  1. jeeperguytj

    jeeperguytj Member

    Joined:
    Jul 30, 2009
    Messages:
    20
    Location:
    Kentucky
    My grandfather has an old Massey Ferguson 240 with a farmhand loader on it with a weird Hydraulic problem. The loader really won't do anything and the bucket won't either (super slow) and it drifts down like crazy. I originally thought it was piston seals leaking until I operated it the other weekend. It has a simple two valve setup with a joystick, the weird thing that threw me off was that when you push the joystick all the way forward it catches like a detent and it's supposed to be in float ( I assume connecting head end to rod end) but the loader raises up. Now I think it could be in the valve, but everything's there to look at and the valve seems to be operating normally. Rear Hydraulics work just fine off the same pump, he replaced the valve a few years ago and claims it was doing similar things. I was going to put the old valve back on it and see if that changes anything. Any insight would be appreciated, also wasn't sure if I should put this in the AG section, figured a Hydraulics problem might be better suited here.

    Thanks in advance,
    Carter
     
  2. willie59

    willie59 Super Moderator

    Joined:
    Dec 21, 2008
    Messages:
    11,588
    Occupation:
    Service Manager
    Location:
    Knoxville TN
    Can you send a few pics of the valve? Sometimes it helps when we can see what your working on. :)
     
  3. jeeperguytj

    jeeperguytj Member

    Joined:
    Jul 30, 2009
    Messages:
    20
    Location:
    Kentucky
    Yea I'll have to get them scanned somewhere though. My original thoughts were that if the oil was bypassing the cylinder seals, when you lower the loader frame (put oil into the rod end), if you open the valve all the way and oil got past the piston seals into the head end then the larger area may allow it to lift instead of lower even though you are putting pump oil into the rod end initially (kind of a crazy thought). When I operated the loader I realized that (i'm pretty sure) the forward detent on the valve should be float, when I put the joystick there the loader will slowly raise up. NO OIL should be going out to the cylinder at all, so it's gotta be in the valve right? Maybe valve stuck open? Or maybe it's not float at all, but a lower detent? I was looking in the operation/parts manual and I glanced at the operation and it said that all the way forward was a float position. I feel like I'm rambling on, but I'll try to get some pictures on here, I'm not that good with computers but I'll try.
     
  4. spitzair

    spitzair Senior Member

    Joined:
    May 4, 2007
    Messages:
    826
    Location:
    Squamish BC (Home), Slave Lake, AB (Work)
    I'm almost inclined to think that maybe he's got the supply from the pump hooked into the outlet of the valve 'cause in float it should, AFAIK, just be open to the return, that might be the reason your arms come up when in float... Just my $0.02...
     
  5. jeeperguytj

    jeeperguytj Member

    Joined:
    Jul 30, 2009
    Messages:
    20
    Location:
    Kentucky
    I've thought about lines hooked up wrong but I'm pretty sure he hasn't been into this thing in a long time and that it's worked fine after he was into it. Also I think other things might be outta wack if that was the case, seems like if he had a supply line somehow hooked to the outlet of the valve then right when you crank the key over it would put oil to a cylinder and make it raise/lower. I'll get to look at it again this weekend so keep your $0.02 coming, I need some more ideas before I go back out there. Thanks fellas.
     
  6. willie59

    willie59 Super Moderator

    Joined:
    Dec 21, 2008
    Messages:
    11,588
    Occupation:
    Service Manager
    Location:
    Knoxville TN
    Nope. When the control valve spools are in neutral/center position, the cyl ports are blocked from supply and return. Think about it, this is what keeps the loader in the air to carry a bucket load, the oil is trapped in the cylinder lines when the valve spool is centered, no connection to supply or return ports.
     
  7. Phil

    Phil Senior Member

    Joined:
    May 2, 2005
    Messages:
    1,067
    Occupation:
    retired operator and mechanic
    Location:
    Southeastern Ontario
    Just some ideas. Try taking the 2 lines to the loader cylinders off and blocking the 4 ports, then see how the bucket cylinder(s) work. Then do the opposite. Check each port A & B, on the valve body with a pressure gauge while you are doing this to see if the valve is building pressure. A cylinder piston problem can cause some strange symptoms. Phil
     
  8. jeeperguytj

    jeeperguytj Member

    Joined:
    Jul 30, 2009
    Messages:
    20
    Location:
    Kentucky
    I read the post previous to the one you're replying to as if he had a line hooked to the outlet of the valve, meaning past the valve or bypassing the valve, or in other words hooking the supply line directly to the cylinder. I appreciate it though and you're exactly right and I hope I'm not insulting you because I'm definitely not trying to. Keep the ideas coming.
     
  9. jeeperguytj

    jeeperguytj Member

    Joined:
    Jul 30, 2009
    Messages:
    20
    Location:
    Kentucky
    Phil I'll definitely try capping the cylinders, and checking pressures. Sorry guys, I haven't really had a chance to do much trouble shooting, and was hoping someone had had a similar problem, maybe not with this machine but with one like it.
     
  10. Phil

    Phil Senior Member

    Joined:
    May 2, 2005
    Messages:
    1,067
    Occupation:
    retired operator and mechanic
    Location:
    Southeastern Ontario
    Hydraulics is not my strong point. I'm a trial and error type so my ideas are somewhat more primitive. Your in good hands with ATCOEQUIP. Phil:)
     
  11. jeeperguytj

    jeeperguytj Member

    Joined:
    Jul 30, 2009
    Messages:
    20
    Location:
    Kentucky
    They aren't my strongest either, and I agree I've read some of the other posts ATCOEQUIP has posted, hey I've seen some of yours too. I can tell there are some sharp mechanics on this website, I'm still learning and this site's been helping me out a ton.
     
  12. willie59

    willie59 Super Moderator

    Joined:
    Dec 21, 2008
    Messages:
    11,588
    Occupation:
    Service Manager
    Location:
    Knoxville TN
    Yeah, I'm watchin' this thread to see what develops, just not enough info about the system for me to venture a guess at this point. Is it an open center valve? Can you work both loader and bucket at the same time, then it probably has internal power beyond porting. I'm like spitzair, the first thing I'd do is verify the pressure and return lines are connected properly. Certainly a tricky problem for sure.
     
  13. willie59

    willie59 Super Moderator

    Joined:
    Dec 21, 2008
    Messages:
    11,588
    Occupation:
    Service Manager
    Location:
    Knoxville TN
    Hey jeeperguytj, what part of KY are you in?
     
  14. jeeperguytj

    jeeperguytj Member

    Joined:
    Jul 30, 2009
    Messages:
    20
    Location:
    Kentucky
    I'm in Louisville, KY, and hopefully I'll be able to find some more stuff on the tractor this weekend. The valve has two spools lift/bucket, and are connected by a linkage with one joystick which you can operate both functions at the same time. I think they are open center. Tomorrow (saturday) I should know some more, I'm at least gonna cap the cylinders and see what they're gonna do, and take apart the valve and see if anything is obvious.

    Does anyone know who makes the digital pressure guage that is shaped like a regular guage, I think it might only have one transducer as well, I saw one a while back but can't remember who makes it. The set you can buy through some of the CAT dealerships is pretty darn expensive.
     
  15. willie59

    willie59 Super Moderator

    Joined:
    Dec 21, 2008
    Messages:
    11,588
    Occupation:
    Service Manager
    Location:
    Knoxville TN
    Louisville, cool! Been through there a couple of times. I'm curious to see how the Phil test works out. We're out here watchin' so keep us posted. :)
     
  16. willie59

    willie59 Super Moderator

    Joined:
    Dec 21, 2008
    Messages:
    11,588
    Occupation:
    Service Manager
    Location:
    Knoxville TN
  17. jeeperguytj

    jeeperguytj Member

    Joined:
    Jul 30, 2009
    Messages:
    20
    Location:
    Kentucky
    Well I went out and operated the tractor. I'm starting to think that the forward detent on the joystick isn't float and more like a return to dig type deal. If you move the valve in just the right spot it'll lift. I capped the cylinders and they drifted like crazy, blown piston seals was my original thought. I think whats happening when you go to lower it and it goes up is that your putting pump oil into the rod end of the cylinder and it's bypassing into the head end which has a larger area and it's causing it to go up, when you push it forward enough it will go down but won't have any down pressure. I really appreciate the help guys, and I'll post as soon as we get the seals and replace them to see if it's the true fix.
     
  18. jeeperguytj

    jeeperguytj Member

    Joined:
    Jul 30, 2009
    Messages:
    20
    Location:
    Kentucky
    Well the cylinder seals were junk. The left lift cylinder seals were almost gone, there was a piece of them in the barrel of the other lift cylinder. Got them resealed, honed the barrels a little to clean up some minor grooves and it works like a champ now. I bush hogged with it for a few hours and never once had to touch the joystick to raise it. Thanks a lot for the help fellows.
     
  19. willie59

    willie59 Super Moderator

    Joined:
    Dec 21, 2008
    Messages:
    11,588
    Occupation:
    Service Manager
    Location:
    Knoxville TN
    Excellent, glad to hear ya got it fixed! :woohoo
     
  20. stock

    stock Senior Member

    Joined:
    Aug 4, 2008
    Messages:
    2,019
    Occupation:
    We have moved on and now were lost....
    Location:
    Eire
    Another fine job Atco.