1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

JLG 400S High Rev when Starting

Discussion in 'Other Construction/Demolition Equipment' started by HozeVig, Jan 26, 2017.

  1. HozeVig

    HozeVig Member

    Joined:
    Oct 16, 2014
    Messages:
    12
    Location:
    Miami, Fl
    Hello,

    We have a JLG 400s s/n- 0300101674 / DEUTZ diesel powered that came back from a job with the following problem.

    When you go to start the machine, sometimes it will crank but not turn on over then sometimes it does turn on but the engine revs EXTREMELY HIGH that we have to shut it off right away. We replaced the throttle actuator thinking it was that but it remains the same.

    Any suggestions on what it could be?
     
  2. Jake McSwegin

    Jake McSwegin New Member

    Joined:
    Mar 20, 2017
    Messages:
    1
    Location:
    Pittsburgh, PA
    check the harness where it goes down underneath the engine. it rubs near the oil pan. Also check your target/actual speeds on the analyzer
     
  3. Rick39

    Rick39 Active Member

    Joined:
    Jan 7, 2017
    Messages:
    29
    Location:
    SE PA
    If it is truly over speeding to more than max governed RPM it's not an electrical issue. If you remove the actuator the engine should run at max governed RPM.

    The springs on the actuator push the rack back toward less fuel delivery. The rack moves according to the governor arm position and flyweight push.

    With the actuator removed reach in the hole and check that the rack moves freely.