1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

Case 580B (reman pump) no fuel at injectors? Why?

Discussion in 'Tractor/Loader/Backhoes' started by WB Automotive, Sep 24, 2009.

  1. WB Automotive

    WB Automotive Active Member

    Joined:
    Jun 25, 2009
    Messages:
    28
    Occupation:
    Apprentice Mechanic
    Location:
    Blooming Grove NY.
    :(Hello, i am in desperate need of help. i seem to be having trouble getting fuel at the injectors. the pump that was installed is a reman pump. i cranked for some time and i still dont see fuel at the injectors.


    H.E.L.P would be greatly appreciated. Thank You Very Much.
     
  2. alrman

    alrman Senior Member

    Joined:
    Jun 20, 2009
    Messages:
    2,001
    Occupation:
    Diesel Fitter;Small Business Owner;Cleaner
    Location:
    QLD Australia
    It has got a manual fuel shut off lever?? Is it in the 'run' position? Later models can look same but have electric shut off. If you have fuel & it's cranking it must deliver fuel to injectors - even if timing is out.
     
  3. Phil

    Phil Senior Member

    Joined:
    May 2, 2005
    Messages:
    1,067
    Occupation:
    retired operator and mechanic
    Location:
    Southeastern Ontario
    WB,
    Since we don't yet know what happened in your last thread, on the same topic, I'll assume your pump was full of fuel, it was turning, no fuel was squirting out of the pump body with the injection lines removed, and the fuel shut-off lever was in the correct position.

    Throttle should be held wide open to prime the pump also.

    I hope the pump supplied to you has been set up for the correct rotation, left hand or right hand, sometimes it is indicated on the decal. I would verify that with the supplier.

    Your pump should not have any stuck components from long term storage, since it has been tested recently.

    It is always a good idea to replace the 2 shaft seals. Engines have been lost through oil dilution.

    Remove the pump and mount it in a vise, carefully wrapped with a protective material like an old coat. Tilt the pump so that the drive end is at a 45 deg angle. Construct a rod with a flat end on one end that will fit the slot inside the pump and can be turned with a variable speed drill on the other end. Fill the pump through the shaft hole with the cleanest diesel you have, preferably what drains through your 2 new fuel filters. Think clean here. Supply clean fuel through a short hose to the fuel inlet fitting. A funnel will do. Drive the pump with the drill, slowly at first, the same direction the engine does. Be very careful of the pump bushings, do not rub them with the tool.

    Once the pump starts squirting fuel out all 4 holes, reinstall it. Crank the engine with the fuel supply line connected, the fuel return line disconnected , the injection lines off, the fuel shut-off in the correct position, and the throttle wide open. Let us know if this does not work. Phil
     
    Last edited: Sep 25, 2009
  4. WB Automotive

    WB Automotive Active Member

    Joined:
    Jun 25, 2009
    Messages:
    28
    Occupation:
    Apprentice Mechanic
    Location:
    Blooming Grove NY.
    ok that seems right... so im asuming the pump is at fault AGAIN...

    Thank You,
     
  5. WB Automotive

    WB Automotive Active Member

    Joined:
    Jun 25, 2009
    Messages:
    28
    Occupation:
    Apprentice Mechanic
    Location:
    Blooming Grove NY.
    Thank You Phil i will get back to you.
     
  6. willie59

    willie59 Super Moderator

    Joined:
    Dec 21, 2008
    Messages:
    11,488
    Occupation:
    Service Manager
    Location:
    Knoxville TN
    Hey Phil. I need to clarify something. You are talking about having the pump drive shaft pulled from the pump body and making a rod to turn the shaft that's down inside the pump body, correct? I was asking WB automotive on his last thread if he had removed the shaft, he said no. I've always been told by the injection shops that whenever you remove the shaft out of one of those Roosa Master pumps that you need to keep the throttle lever in full throttle position during the time the shaft is removed or the governor counterweights will drop out of position.
     
  7. gggraham

    gggraham Senior Member

    Joined:
    Feb 13, 2009
    Messages:
    305
    Occupation:
    Licensed Heavy Duty Equipment Mechanic
    Location:
    Canada
    Atco: We always remove them with the throttle wired back. Arlman is also correct the pump timing could be completely screwed up it would still deliver fuel to the injectors just not at the right time. I'd be more inclined to think that there is a fuel shut off problem
     
  8. Phil

    Phil Senior Member

    Joined:
    May 2, 2005
    Messages:
    1,067
    Occupation:
    retired operator and mechanic
    Location:
    Southeastern Ontario
    ATCO,
    I never heard of that precaution on these DB pumps. I read back through my 580D service manual which shows step by step removal of the injection pump. It actually shows the earlier model pump with the manual shut-off. No mention of the throttle lever wired in full throttle position.

    I'm going to ask next time I go to the local injection shop. Thanks for bringing that up ATCO and gggraham. Might save me some grief down the road.

    My manual shows using a large screwdriver(a clean one), inserted into the pump, to align timing marks in the window.

    To replace the injection pump, complete with shaft, on a G188 is not easy. Coolant has to be drained, and a large cover removed. Not much room to work with the rad in place.....

    Most of these pumps get replaced using the old shaft still in place, with new shaft seals installed back to back. Phil
     
  9. willie59

    willie59 Super Moderator

    Joined:
    Dec 21, 2008
    Messages:
    11,488
    Occupation:
    Service Manager
    Location:
    Knoxville TN
    I can't confirm it Phil, I've just been told that by injection shops. And I lean toward listening to their advice. :D
     
  10. Phil

    Phil Senior Member

    Joined:
    May 2, 2005
    Messages:
    1,067
    Occupation:
    retired operator and mechanic
    Location:
    Southeastern Ontario
    Thanks ATCO,
    I will check that out and get back to you. Good to post info like that. I better sign off it's almost bedtime. Phil:)
     
  11. grapeman

    grapeman Member

    Joined:
    Apr 25, 2011
    Messages:
    12
    Location:
    California
    580b running out of fuel

    I have a case 580B hoe. it idles just fine for as long as you want. however, when you drive the tractor, it runs for about 3 or 4 minutes then runs out of fuel. if you let it set for about 5 minutes, it will fire up again. But the same process have again.
    It seems like it is running out of fuel. I have changed the fuel filter, but no improvement. any suggestion?
     
  12. alrman

    alrman Senior Member

    Joined:
    Jun 20, 2009
    Messages:
    2,001
    Occupation:
    Diesel Fitter;Small Business Owner;Cleaner
    Location:
    QLD Australia
    Welcome to the forum Grapeman.

    You most likely have a blockage in the fuel return line. Not 100% sure on a 580B about this, as the parts info at Casece does not show the valve I am thinking of.......
    this is a pic of a 580D

    On the top of the injector pump there may be a fitting with a tiny glass ball (check valve) in it. These get blocked with debris & cause just the problem you describe.
    Below is a pic - item #46. If you have this remove it & clear it using some compressed air. If you don't have one of these fittings remove the lines & blow air between pump & tank.

    For what it is worth, be sure you have a good delivery supply of fuel to the pump.

    Bad news is if you do have check valve & it is blocked, you clear it & runs fine for a while & blocks again - your injector pump needs an overhaul as it has a ring in it that is breaking up & causing the problem.

    I've tried searching forum for this info, as I'm sure it has been disscussed numerous times before - but I think it is lost in threads with offline subjects, as this one is.......
     

    Attached Files:

  13. stock

    stock Senior Member

    Joined:
    Aug 4, 2008
    Messages:
    2,018
    Occupation:
    We have moved on and now were lost....
    Location:
    Eire
    Check your tank as it may have a suction filter on the supply line to the pump.................................don't forget to look at item 14 in the picture above as it is also a filter.............
     
  14. Ed T

    Ed T Member

    Joined:
    Oct 18, 2011
    Messages:
    8
    Location:
    Arkansas
    '93 Case K Super King Backhoe

    I've read some of your comment on fuel injection pumps for backhoe. My backhoe will not start and I've been told that the injector pump is out. No fuel coming out of back, all lines are free with plenty of fuel, everything is bled out. I've taken it off and put it on bench. Filled it with fuel and tested it. Nothing comes out the back. I'm convinced it is in the pump, no pressure. Can anyone tell me how to get center shaft out of pump without doing damage. On front I've passed the second lockring in dismanteling it and took off what I could on back. Is shaft pressed out or are there more lock rings? Also can anyone tell me where I can get replacement parts as I've been told Case will not sell them. They want from $900 to $1600 for a replacement. I'm retired and can't afford that. I do all my own mechanic work and know what I'm up aganist. Maybe someone can help me. Thanks. Ed T
     
  15. stock

    stock Senior Member

    Joined:
    Aug 4, 2008
    Messages:
    2,018
    Occupation:
    We have moved on and now were lost....
    Location:
    Eire
    Ed is that a rotary pump? is it a standyne, Cav or Bosh ? regardless they are not something to be played with, How do you propose to calibrate the pump when you have it rebuilt, You might be able to get a specialists injector pump repair shop to recon it for you at a more realistic price.
     
  16. alrman

    alrman Senior Member

    Joined:
    Jun 20, 2009
    Messages:
    2,001
    Occupation:
    Diesel Fitter;Small Business Owner;Cleaner
    Location:
    QLD Australia
    Ed,
    Are you sure the electric shut-off solenoid is OK? Without 12v or if solonoid is u/s it won't pump fuel.
     
  17. GWS

    GWS Well-Known Member

    Joined:
    May 22, 2011
    Messages:
    154
    Location:
    Oklahoma
    After replacing the flex ring and seals in the injection pump on my 580C I am having the same issue with no fuel to the injectors. Fuel is being pumped through the pump and out of the check valve at the top but none to the injector lines. I spoke with a diesel shop and they told me there are only a couple of things that will cause this.
    1) Fuel is shut off to the pressure side of the pump (same as when you pull the fuel shut off lever)
    2) The input shaft has sheared due to a jammed governor weight.
    3) metering valve is not working

    I don't think it is a sheared shaft due to the fact I checked the spin of the pump after reassembling and also the feed pump in the back is pumping fuel through the pump. I pulled the top off the pump, sucked out the fuel and checked the movement of the governor and fuel shutoff and they seem to be working correctly.

    I am going to remove it this weekend and tear it down to find the problem and report back with photos of the tear down and what I find.
     
  18. Ed T

    Ed T Member

    Joined:
    Oct 18, 2011
    Messages:
    8
    Location:
    Arkansas
    Thanks. It's a CVA. Will have to think this over. Don't know which way to go.
     
  19. Ed T

    Ed T Member

    Joined:
    Oct 18, 2011
    Messages:
    8
    Location:
    Arkansas
    I don't have a manual, where is the solenoid located? Thank you for your come back. I appreciate the help. Ed
     
  20. Ed T

    Ed T Member

    Joined:
    Oct 18, 2011
    Messages:
    8
    Location:
    Arkansas
    GWS: Thanks for the info. Let me know what you find out. I just put a high pressure on the back line of pump but still nothing comes out. Let me know how far into shaft you go and are you going to go inside of pump. "Have you thought about a gasoline motor? I have" Thank you for your comment.