1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

ASV RC100 charging issue

Discussion in 'Compact Track/Multi Terrain Loaders' started by southernman13, Jun 17, 2017.

  1. southernman13

    southernman13 Senior Member

    Joined:
    May 13, 2008
    Messages:
    329
    Occupation:
    Retired
    Location:
    Florida,Ga,Tn
    06 model not charging. I hit a tree while backing up pretty good but no more than many times before. I'm. It sure that contributed to it bit it did quit charging that day. I didn't notice it till a little bit later. Anyway I've checked fuses and connections. So I got a new aftermarket alternator and put it on. It's still not charging. I don't think it's a bad battery because it still starts and runs. The battery of course is getting weaker. I've had it on charge all nite and I'm m going to check it this morning. Just for chits and giggles I'm going to change the battery out to see if it makes a difference. Only other thing i can think of is the new alternator is bad as well or I'm missing something somewhere in the electrical routing. It's not a dead short and I've checked the alternator diode in fuse box. I may try and bench test the old alternator with a drill and battery. No one around here in Cuthbert has anything to test it with. It's a simple 2 wire alternator. B+ and D+ terminal for the dash light. If anyone has a schematic it would help. Thanks
     
  2. f311fr1

    f311fr1 Well-Known Member

    Joined:
    May 12, 2016
    Messages:
    224
    Location:
    Middle TN
    I have attached an electrical schematic for an RC100
     

    Attached Files:

  3. southernman13

    southernman13 Senior Member

    Joined:
    May 13, 2008
    Messages:
    329
    Occupation:
    Retired
    Location:
    Florida,Ga,Tn
    Thank you sir. I'm pretty sure the new alternator isn't charging but this will give more to go on.
     
  4. mikebramel

    mikebramel Senior Member

    Joined:
    Jul 16, 2012
    Messages:
    1,121
    Location:
    milwaukee
    Check the fuse
     
  5. southernman13

    southernman13 Senior Member

    Joined:
    May 13, 2008
    Messages:
    329
    Occupation:
    Retired
    Location:
    Florida,Ga,Tn
    Which one. I've checked all I know to check I have voltage ont the orange 12v wire that goes to B+ on back of alternator so I have battery voltage. And the D+ small grey wire the only other wire on it illuminates the dash light. I've taken the orange wire off the alternator and connected another wire to the alternator and ran it direct to the +battery terminal and it still doesn't charge. I've also ran that same external wire direct to another battery outside of the machine with a ground from that battery to the ground on the machine. This eliminates the battery in the machine and any circuit and it still isn't charging. Other than taking the alternator somewhere to have it bench tested I'm out of ideas. I am going to take it somewhere tomorrow if you can find a place snd and see what they find
     
    bobcan likes this.
  6. southernman13

    southernman13 Senior Member

    Joined:
    May 13, 2008
    Messages:
    329
    Occupation:
    Retired
    Location:
    Florida,Ga,Tn
    Tada!! Fixed it. They sent me a new one to replace the other new one. Well the housing was wrong and it wouldn't mount up. When I got the first new one I had to change the pulley. However my pulley required a spacer to keep it off the alternator housing. I made one from a 5/8 lock washer. It fit in the hole and around th shaft. The second new came with the proper spacer so I replaced the lock washer that I had cut to fit with the proper spacer. Well I guess the lock washer must have been touching the housing or was close enough to cause interference or grounded out the aternator because now it is working and charging as it should be. I couldn't see where it was touching and it would spin freely but I guess it was close enough to cause it issues. Yeeeehaw!