1. Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

1998 daewoo DSL801 servo problem

Discussion in 'Skid Steers' started by cooperthumb, Mar 16, 2014.

  1. cooperthumb

    cooperthumb New Member

    Joined:
    Mar 16, 2014
    Messages:
    1
    Location:
    St. Louis
    Hello
    This must be the first website I've seen that discusses the daewoo DSL801
    Anyway my problem is:

    The servo that bolts to the front of the engine powering the hydraulics
    Is mounted to the plate covering the flywheel
    My issue has been since I bought it is those 6 bolts holding the servo in place kept breaking
    1 or 2 at a time so every few months I would lift the cab pull that servo out
    Tap the broke bolts and put new in. Nothing worked I've tried lock tight, and gasket seal around the threads and they seem to get loose an break
    The last time right at a year ago I pulled the motor and servo and bought a little longer grade 8 bolts and threaded them from the inside out so the nuts were on the outside of the servo.
    This has lasted thus far but my daewoo started creeping when you start it and I know now it's a sign of the servo loose
    I'd like to know what might be the issue? What's the problem?
    Also as I've pulled the engine now a couple times and the servo 4 times I've noticed with the servo it slides on that spline gear out of the engine and in mine that's it for support there is no pedestal or mount to support the front of those tandem pumps. And those pumps because of the awkwardness of placement aren't the lightest
    Any insight would be greatly appreciated
     
  2. Jason1234567

    Jason1234567 New Member

    Joined:
    Jun 17, 2017
    Messages:
    1
    Location:
    Canada
    Hi. Do you still have this skid steer and did you fix the problem? I have the exact same problem