Results 1 to 4 of 4

Thread: Volvo A30C Transmission Problems

  1. #1
    Probationary Member
    Join Date
    Nov 2016
    Location
    NC
    Posts
    2

    Volvo A30C Transmission Problems

    We have a A30C that shifts into reverse on start up. When you turn the key off, but do not kill the engine it relaxes back into neutral. Because of this we believe it to be an electrical issue. It will still operate normally, i.e. shift into forward gears. We found a bad solenoid in the transmission, but it still does it. We bypassed the ECU and it stops. After replacing the ECU it still does it. We have gone through all the harnesses & connections, we check the shifter. We have gone through every test in the repair manual. We just picked it up from Volvo after 2 months. They rebuilt 1 harness ordered a ECU from Sweden and exhausted all their options. Their next step was a $ 40,000.00 trans. We are at a brick wall and hoping some one has some advice. PLEASE!?!?

  2. #2
    Senior Member
    Join Date
    Aug 2015
    Location
    victoria,Australia
    Posts
    400
    Hi GYB, i would suggest you need to work backwoods here and see what pressures are at the clutch stations
    For reverse to engage you need clutch K2 engaged and either brake B4 or B5 engaged depending whether in high or low.
    install gages in the ports shown and start machine, if there is pressure in K2 you have an hydraulic or electrical issue if you have no pressure and reverse still engages you probably have warped clutch plates in K2
    What was in the filters ? what was the lead up to the problem?
    Name:  shift matrix.jpg
Views: 134
Size:  57.9 KBName:  test points.jpg
Views: 132
Size:  39.6 KBName:  test pressures.jpg
Views: 132
Size:  27.3 KB

    Mark

  3. #3
    Probationary Member
    Join Date
    Nov 2016
    Location
    NC
    Posts
    2
    Thanks for the response, Mark250. We will definitely try your suggestion. As far as the filters and the trans. (internal), everything was clean (very, very little metal, no more than normal wear and tear). The problem pretty much just happened over night. One day it was fine and the next it was trying to run in two gears. Thanks again.

  4. #4
    Junior Member
    Join Date
    Dec 2016
    Location
    Michigan
    Posts
    6
    I had the same problem with the same machine in the end one of the clutch packs welded itself together. We did harnesses solenoids ECM the same stuff you have done and in the end it was the transmission needed a rebuild.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •