Page 1 of 3 123 LastLast
Results 1 to 15 of 44

Thread: John Deere 310D electrical problems, please help!

  1. #1
    Junior Member
    Join Date
    Nov 2012
    Location
    Owenton, KY
    Posts
    22

    John Deere 310D electrical problems, please help!

    Hello All, I am Jim. I am working on my neighbor's John Deere backhoe model 310D, serial# TO310DG813560. The hoe will not crank the when the key is turned, the alarm just sounds and the stop light comes on. The hoe will start and run just fine if you jump the solenoid on the starter, however. I am trying to diagnose the source of the electrical problem preventing the key from cranking the machine. Also, I know at this time, the alt is new (neighbor replaced it before I got involved) and key switch is also new.

    I start at the beginning with a test light, and no power is going to the solenoid from the key switch to signal the starter to crank, so I start checking fuses. The MFWD/ALT fuse is blown and blows a new one immediately upon making contact. Its obvious that the wire, labled P13, is shorted somewhere, but I can't find where it goes to. The harness in the dash has never been modified so it is still banded tightly together. Does anyone have a wiring schematic for this machine, or maybe have any idea where this wire runs to? Thanks, Jim.

  2. #2
    Junior Member
    Join Date
    Nov 2012
    Location
    Owenton, KY
    Posts
    22
    Well, I found P13....LOL! I was going over the wiring on the back of the alternator from where the neighbor put it back on and he switched the ground with the 12v signal wire, P13, that tells the alternator to energize. I sure hope that didn't blow anything. Ok, found that and put a new fuse in the MFWD/ALT position and that part is fixed.

    It still wont try to crank when the key is turned. The "information" light comes on, alarm and stop lights come on, when the key is released back to the "on" position after trying to crank, the "information" light and ALT warning light stays on. When the key switch is turned, power comes out of the switch on the crank terminal, goes through the fuse (which is good) and into the neutral relay.

    Any suggestions would be helpful........

  3. #3
    Senior Member Deon's Avatar
    Join Date
    Jul 2010
    Location
    Nova Scotia, Canada
    Posts
    519
    Ky, I'm not sure I can help but I've got something you can check. Your serial number is more recent than mine. I have a relay in the side console that the ignition switch needs to activate to turn the starter. I can see the relay in the Deere parts catalogue. On your model that is after serial numbers ending with 802200, that particular relay is not used. But there is different relay showing for the newer serial number but the catalogue does not list what it's for. I'm thinking is must be for the starter.
    If you have not already looked into the side console yourself, it may be wise to lift the cover and look to see if there is a relay connected to the ignition switch. If so you may find your troubles there. You probably already know this but a test light or meter won't help much here as the relay may click and make connection but a burnt contact won't carry enough amps to turn the starter.
    Good luck.
    Deon
    Last edited by Deon; 11-04-2012 at 08:46 PM.

  4. #4
    Junior Member
    Join Date
    Nov 2012
    Location
    Owenton, KY
    Posts
    22
    Deon, thank you for your reply!
    Best I can tell, there are several relays that affect the starter circuit. I am pretty sure that this is how the "safety switches" that prevent the machine from being started when it isn't in neutral and when the parking brake isn't engaged. I switched out a couple of them and didn't have any luck.

    I am working with a local dealer now to try to get a printout of the wire harness. I am hoping this will greatly reduce the amount of time needed to find the short or bad safety switch that is preventing it from cranking.

    There is a black plastic box under the ignition switch, it has about 5 or 6 wires running into it and out of it. It is bolted to the framework under the removeable panel that houses the ignition switch, accessory switches, fuse and relay panel. Inside the box is just a circuit board, any idea what it is?

    Also, if you would please, could you post up the link to the parts catalog? I might be able to use that to tell what some of the componets are. Thanks, Jim.

  5. #5
    Senior Member Deon's Avatar
    Join Date
    Jul 2010
    Location
    Nova Scotia, Canada
    Posts
    519
    Ky,

    Here is the Deere parts link. http://jdpc.deere.com/jdpc/servlet/c...del&model=310D

    The relay I am reffering to is not a safety switch relay but the main heavy relay between the key switch and starter solenoid. Mine looks something like the old fashion
    starter relay like you would find in a 1975 Ford F150. Some people call this the starter solenoid. A black roundish thing with ring connectors. Yours may not look the same but this is what mine has.

  6. #6
    Senior Member JeremiahSr's Avatar
    Join Date
    Sep 2010
    Location
    Houston, Tx
    Posts
    198
    I have this on my computer already. Couldn't find a schematic. The alternator, differential lock solenoid or the MFWD solenoid or wiring to either 1 can cause this. There are several inline diodes inside of left main frame. right beside the trans. If you have checked your alternator and its wires the other 2 systems share this fuse. Hope this helps.


    Name:  11.jpg
Views: 6138
Size:  58.3 KBName:  22.jpg
Views: 5652
Size:  77.0 KB
    "If It Burns Diesel and Pushes Dirt, We Can Fix It!"
    We Do It Clean, Right and Tight....All Day....All Night!


    http://www.bbdieselserviceinc.com

  7. #7
    Senior Member JeremiahSr's Avatar
    Join Date
    Sep 2010
    Location
    Houston, Tx
    Posts
    198
    Sorry just seen you got that fuse blowing problem fixed. In the pic above it is showing a start relay (K1) Does that have a small solenoid/relay switch mounted to back of console? It looks like it would be next to where horn is mounted?
    "If It Burns Diesel and Pushes Dirt, We Can Fix It!"
    We Do It Clean, Right and Tight....All Day....All Night!


    http://www.bbdieselserviceinc.com

  8. #8
    Junior Member
    Join Date
    Nov 2012
    Location
    Owenton, KY
    Posts
    22
    Sorry it has taken me so long to get back here. I have been working 16 hour days this week and it hasn't left me much time for the net.

    Deon, I have seen the Ford solenoid looking thing that your talking about, but when I probed and tested it appeared to be a main power relay for all the circuits in the control box. It turns on when the key is switched on and then turns off when the key is turned to off. It stays hot as long as the key is in the on position, not the crank position. Thank you for posting the link to the Deere catalog!!

    Jeremiah, I really appreciate your help! I don't think this unit has the relay your speaking of, but I am not positive. It will be Sunday before I have a chance to look at it again but I will find out for sure then.

  9. #9
    Member johnny_waz's Avatar
    Join Date
    Aug 2012
    Location
    Michigan
    Posts
    54
    Try swapping known good relays into the K5, and K6 positions in the above diagram. It sounds to me like your hoe thinks its in gear.

  10. #10
    Member johnny_waz's Avatar
    Join Date
    Aug 2012
    Location
    Michigan
    Posts
    54
    If that does not produce results, i'd start checking the diodes next like JeremiahSr suggested.

  11. #11
    Member johnny_waz's Avatar
    Join Date
    Aug 2012
    Location
    Michigan
    Posts
    54
    Also, FYI your machine should have that K1 starter relay. The parts catalog link Deon posted is VERY accurate, and it shows 1. That link is Jonn Deere Parts Online, and the dealers use the same system for looking up and ordering parts.
    Last edited by johnny_waz; 11-09-2012 at 02:56 PM.

  12. #12
    Member johnny_waz's Avatar
    Join Date
    Aug 2012
    Location
    Michigan
    Posts
    54
    I'm curious what that 12volt logic module controls on your particular machine? Part number AT107670, that bad boy is $170 if its bad. Ouch!

  13. #13
    Junior Member
    Join Date
    Nov 2012
    Location
    Owenton, KY
    Posts
    22
    I don't have a clue what the logic module does either John, and I didn't have any luck with a wiring schematic either. I was told by the local dealer that they are a landscape dealer and not a heavy equipment dealer that they cannot download the file I need. The parts catalog that Deon posted above has been a big help though.

    Do you have any idea how to test the diodes?

    Yes, you are correct, the hoe acts like its in gear when you try to crank it. That's why I am spending the time testing everything from the switch back is to properly diagnose this problem. I am going to spend some more time with it tomorrow after church and hope I can at least figure out where the problem is so stay tuned....LOL!!

  14. #14
    Senior Member JeremiahSr's Avatar
    Join Date
    Sep 2010
    Location
    Houston, Tx
    Posts
    198
    The print out i put up there is what is in the service manual. There is a schematic but i cant find mine. To test diodes get a multi-meter. Most have a setting to test diodes. Shouold run 1.5 volts 1 way but when you swap leads there should be zero voltage.
    "If It Burns Diesel and Pushes Dirt, We Can Fix It!"
    We Do It Clean, Right and Tight....All Day....All Night!


    http://www.bbdieselserviceinc.com

  15. #15
    Junior Member
    Join Date
    Nov 2012
    Location
    Owenton, KY
    Posts
    22
    Ok, Been working on the hoe for a little bit and I have come up with this. Power to crank the engine comes out of the ignition switch and runs through the "start fuse" then from there through the neutral safety switch relay located right next to the fuses. The neutral safety switch relay is K6 in the diagram above. From there is disappears into the big fat convoluted tubing that goes out of the console and heads under the machine. I found the K1 start relay under the hood. I probed the terminals of this relay to determine how it was set up and then tested it and it is working fine, however it is not being told to crank the engine when the key is turned to the "crank" position. So I am guessing that this relay is there to put another safety switch in the system. I am thinking parking brake??? Does anyone have any idea what controls this relay?

    I forgot to mention above in my first post that I don't have any experience working on heavy equipment, however I have many years of experience working on about every other type of automotive, farm equipment, other machinery and lawn equipment electrical systems.

    The diodes, do they look like a rubber two prong electrical terminal with a jumper pushed into it? I found one of these under the dash then I found a bank of three zip-tied together, under the machine right over top of the front axle driveshaft and next to what looks like the main hydraulic filter.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •